aboutsummaryrefslogtreecommitdiff
path: root/nls/pt_BR/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'nls/pt_BR/Makefile.am')
-rw-r--r--nls/pt_BR/Makefile.am30
1 files changed, 17 insertions, 13 deletions
diff --git a/nls/pt_BR/Makefile.am b/nls/pt_BR/Makefile.am
index 197c57d..4745ce1 100644
--- a/nls/pt_BR/Makefile.am
+++ b/nls/pt_BR/Makefile.am
@@ -1,29 +1,33 @@
1# nls/pt_BR/Makefile.am for Blackbox-0.61.x - an X11 Window Manager 1# nls/pt_BR/Makefile.am for Fluxbox - an X11 Window Manager
2
3THE_LANG = pt_BR
4CODESET = ISO-8859-1
2 5
3NLSTEST = @NLS@ 6NLSTEST = @NLS@
4CLEANFILES = blackbox.cat 7CLEANFILES = fluxbox.cat
5MAINTAINERCLEANFILES = Makefile.in Translation.m 8MAINTAINERCLEANFILES = Makefile.in Translation.m
6MFILES = BaseDisplay.m Basemenu.m Configmenu.m Icon.m Image.m Screen.m Slit.m Toolbar.m Window.m Windowmenu.m Workspace.m Workspacemenu.m blackbox.m common.m main.m bsetroot.m 9MFILES = BaseDisplay.m Basemenu.m Configmenu.m Icon.m Image.m Screen.m Slit.m Toolbar.m Window.m Windowmenu.m Workspace.m Workspacemenu.m fluxbox.m common.m main.m bsetroot.m
7EXTRA_DIST=$(MFILES) 10EXTRA_DIST=$(MFILES)
8all-local: blackbox.cat 11all-local: fluxbox.cat
9install-data-local: blackbox.cat 12install-data-local: fluxbox.cat
10 @if test x$(NLSTEST) = "x-DNLS"; then \ 13 @if test x$(NLSTEST) = "x-DNLS"; then \
11 echo "Installing catalog in $(DESTDIR)$(pkgdatadir)/nls/pr_BR"; \ 14 echo "Installing catalog in $(DESTDIR)$(pkgdatadir)/nls/$(THE_LANG)"; \
12 $(mkinstalldirs) $(DESTDIR)$(pkgdatadir)/nls/pt_BR; \ 15 $(mkinstalldirs) $(DESTDIR)$(pkgdatadir)/nls/$(THE_LANG); \
13 $(INSTALL_DATA) blackbox.cat $(DESTDIR)$(pkgdatadir)/nls/pt_BR; \ 16 $(INSTALL_DATA) fluxbox.cat $(DESTDIR)$(pkgdatadir)/nls/$(THE_LANG); \
14 fi 17 fi
15uninstall-local: 18uninstall-local:
16 @if test x$(NLSTEST) = "x-DNLS"; then \ 19 @if test x$(NLSTEST) = "x-DNLS"; then \
17 rm -f $(DESTDIR)$(pkgdatadir)/nls/pt_BR/blackbox.cat; \ 20 rm -f $(DESTDIR)$(pkgdatadir)/nls/$(THE_LANG)/fluxbox.cat; \
18 rmdir $(DESTDIR)$(pkgdatadir)/nls/pt_BR; \ 21 rmdir $(DESTDIR)$(pkgdatadir)/nls/$(THE_LANG); \
19 fi 22 fi
20 23
21Translation.m: $(MFILES) 24Translation.m: $(MFILES)
22 @if test x$(NLSTEST) = "x-DNLS"; then \ 25 @if test x$(NLSTEST) = "x-DNLS"; then \
23 awk -f ../convert.awk output=Translation.m $(MFILES); \ 26 rm -f Translation.m; \
27 awk -f ../convert.awk codeset=$(CODESET) output=Translation.m $(MFILES); \
24 fi 28 fi
25 29
26blackbox.cat: Translation.m 30fluxbox.cat: Translation.m
27 @if test x$(NLSTEST) = "x-DNLS"; then \ 31 @if test x$(NLSTEST) = "x-DNLS"; then \
28 $(gencat_cmd) blackbox.cat Translation.m; \ 32 LANG=$(THE_LANG) $(gencat_cmd) fluxbox.cat Translation.m; \
29 fi 33 fi