aboutsummaryrefslogtreecommitdiff
path: root/nls/ja_JP/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'nls/ja_JP/Makefile.am')
-rw-r--r--nls/ja_JP/Makefile.am33
1 files changed, 33 insertions, 0 deletions
diff --git a/nls/ja_JP/Makefile.am b/nls/ja_JP/Makefile.am
new file mode 100644
index 0000000..dcaf37b
--- /dev/null
+++ b/nls/ja_JP/Makefile.am
@@ -0,0 +1,33 @@
1# nls/ja_JP/Makefile.am for Fluxbox - an X11 Window Manager
2
3THE_LANG = ja_JP
4CODESET = eucJP
5
6NLSTEST = @NLS@
7CLEANFILES = fluxbox.cat
8MAINTAINERCLEANFILES = Makefile.in Translation.m
9MFILES = BaseDisplay.m Basemenu.m Configmenu.m Icon.m Image.m Screen.m Slit.m Toolbar.m Window.m Windowmenu.m Workspace.m Workspacemenu.m fluxbox.m common.m main.m bsetroot.m
10EXTRA_DIST=$(MFILES)
11all-local: fluxbox.cat
12install-data-local: fluxbox.cat
13 @if test x$(NLSTEST) = "x-DNLS"; then \
14 echo "Installing catalog in $(DESTDIR)$(pkgdatadir)/nls/$(THE_LANG)"; \
15 $(mkinstalldirs) $(DESTDIR)$(pkgdatadir)/nls/$(THE_LANG); \
16 $(INSTALL_DATA) fluxbox.cat $(DESTDIR)$(pkgdatadir)/nls/$(THE_LANG); \
17 fi
18uninstall-local:
19 @if test x$(NLSTEST) = "x-DNLS"; then \
20 rm -f $(DESTDIR)$(pkgdatadir)/nls/$(THE_LANG)/fluxbox.cat; \
21 rmdir $(DESTDIR)$(pkgdatadir)/nls/$(THE_LANG); \
22 fi
23
24Translation.m: $(MFILES)
25 @if test x$(NLSTEST) = "x-DNLS"; then \
26 rm -f Translation.m; \
27 awk -f ../convert.awk codeset=$(CODESET) output=Translation.m $(MFILES); \
28 fi
29
30fluxbox.cat: Translation.m
31 @if test x$(NLSTEST) = "x-DNLS"; then \
32 LANG=$(THE_LANG) $(gencat_cmd) fluxbox.cat Translation.m; \
33 fi