aboutsummaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in279
1 files changed, 279 insertions, 0 deletions
diff --git a/configure.in b/configure.in
new file mode 100644
index 0000000..7b58aa0
--- /dev/null
+++ b/configure.in
@@ -0,0 +1,279 @@
1dnl configure.in for Fluxbox - created from configure.in Blackbox 0.61.1
2dnl Initialize autoconf and automake
3AC_INIT(src/main.cc)
4AM_INIT_AUTOMAKE(fluxbox,0.1.5,no-define)
5
6dnl Determine default prefix
7test x$prefix = "xNONE" && prefix="$ac_default_prefix"
8
9dnl Check for various flavors of UNIX(r)
10dnl AC_AIX
11dnl AC_ISC_POSIX
12
13dnl TODO: do this
14dnl AC_LANG_CPLUSPLUS
15
16dnl Locate required external software
17AC_PROG_CC
18AC_PROG_CXX
19AC_PROG_INSTALL
20AM_PROG_LIBTOOL
21
22AC_CHECK_PROGS(regex_cmd, sed)
23if test x$regex_cmd = "x"; then
24 AC_MSG_ERROR([error. sed is required to build the data files.])
25fi
26
27dnl Check for system header files
28AC_HEADER_STDC
29AC_CHECK_HEADERS(errno.h ctype.h dirent.h fcntl.h libgen.h locale.h nl_types.h process.h signal.h stdarg.h stdio.h time.h unistd.h sys/param.h sys/select.h sys/signal.h sys/stat.h sys/time.h sys/types.h sys/wait.h)
30AC_HEADER_TIME
31
32dnl Check for existance of basename(), setlocale() and strftime()
33AC_CHECK_FUNCS(basename, , AC_CHECK_LIB(gen, basename, LIBS="$LIBS -lgen"))
34AC_CHECK_FUNCS(getpid setlocale sigaction strftime strcasestr snprintf vsnprintf catopen catgets catclose)
35AC_CHECK_LIB(nsl, t_open, LIBS="$LIBS -lnsl")
36AC_CHECK_LIB(socket, socket, LIBS="$LIBS -lsocket")
37
38dnl Check for X headers and libraries
39AC_PATH_X
40AC_PATH_XTRA
41
42test x$no_x = "xyes" && AC_MSG_ERROR([Fluxbox requires the X Window System libraries and headers.])
43
44test x$x_includes = "x" && x_includes="/usr/include"
45test x$x_libraries = "x" && x_libraries="/usr/lib"
46
47CFLAGS="$CFLAGS $X_CFLAGS"
48CXXFLAGS="$CXXFLAGS $X_CFLAGS"
49LIBS="$LIBS $X_LIBS"
50LDFLAGS="$LDFLAGS $LIBS $X_PRE_LIBS"
51
52dnl Check for required functions in -lX11
53AC_CHECK_LIB(X11, XOpenDisplay,
54 LIBS="$LIBS -lX11",
55 AC_MSG_ERROR([Could not find XOpenDisplay in -lX11.])
56)
57
58LIBS="$LIBS $X_EXTRA_LIBS"
59
60Xext_lib=""
61
62dnl Check for XShape extension support and proper library files.
63SHAPE=""
64AC_MSG_CHECKING([whether to build support for the XShape extension])
65AC_ARG_ENABLE(
66 shape, [ --enable-shape enable support of the XShape extension [default=yes]])
67
68: ${enableval="yes"}
69if test x$enableval = "xyes"; then
70 AC_MSG_RESULT([yes])
71 AC_CHECK_LIB(Xext, XShapeCombineShape,
72 AC_MSG_CHECKING([for X11/extensions/shape.h])
73 AC_TRY_LINK(
74#include <X11/Xlib.h>
75#include <X11/Xutil.h>
76#include <X11/extensions/shape.h>
77, long foo = ShapeSet,
78 AC_MSG_RESULT([yes])
79 SHAPE="-DSHAPE"; Xext_lib="-lXext",
80 AC_MSG_RESULT([no])
81 )
82 )
83else
84 AC_MSG_RESULT([no])
85fi
86AC_SUBST(SHAPE)
87
88LIBS="$LIBS $Xext_lib"
89
90dnl Check for the Slit
91SLIT=""
92AC_MSG_CHECKING([whether to include the Slit])
93AC_ARG_ENABLE(
94 slit, [ --enable-slit include code for the Slit [default=yes]],
95 if test x$enableval = "xyes"; then
96 AC_MSG_RESULT([yes])
97 SLIT="-DSLIT"
98 else
99 AC_MSG_RESULT([no])
100 fi,
101 AC_MSG_RESULT([yes])
102 SLIT="-DSLIT"
103)
104AC_SUBST(SLIT)
105
106dnl Check for the new WM Spec
107NEWWMSPEC=""
108AC_MSG_CHECKING([whether to include the new WM Spec (DOES NOTHING)])
109AC_ARG_ENABLE(
110 newspec,
111[ --enable-newspec include code for the new WM Spec (DOES NOTHING)
112 [default=no]],
113 if test x$enableval = "xyes"; then
114 AC_MSG_RESULT([yes])
115 NEWWMSPEC="-DNEWWMSPEC"
116 else
117 AC_MSG_RESULT([no])
118 fi,
119 AC_MSG_RESULT([no])
120)
121AC_SUBST(NEWWMSPEC)
122
123
124dnl Check for Interlacing
125INTERLACE=""
126AC_MSG_CHECKING([whether to include interlacing image code])
127AC_ARG_ENABLE(
128 interlace, [ --enable-interlace include code for image interlacing [default=yes]],
129 if test x$enableval = "xyes"; then
130 AC_MSG_RESULT([yes])
131 INTERLACE="-DINTERLACE"
132 else
133 AC_MSG_RESULT([no])
134 fi,
135 AC_MSG_RESULT([yes])
136 INTERLACE="-DINTERLACE"
137)
138AC_SUBST(INTERLACE)
139
140dnl Check for ordered 8bpp dithering
141ORDEREDPSEUDO=""
142AC_MSG_CHECKING([whether to include Pseudocolor ordered dithering code])
143AC_ARG_ENABLE(ordered-pseudo,
144[ --enable-ordered-pseudo include code for ordered pseudocolor (8bpp)
145 dithering [default=no]],
146 if test x$enableval = "xyes"; then
147 AC_MSG_RESULT([yes])
148 ORDEREDPSEUDO="-DORDEREDPSEUDO"
149 else
150 AC_MSG_RESULT([no])
151 fi,
152 AC_MSG_RESULT([no])
153)
154AC_SUBST(ORDEREDPSEUDO)
155
156dnl Check whether to include debugging code
157DEBUG=""
158AC_MSG_CHECKING([whether to include verbose debugging code])
159AC_ARG_ENABLE(debug,
160 [ --enable-debug include verbose debugging code [default=no]],
161 if test x$enableval = "xyes"; then
162 AC_MSG_RESULT([yes])
163 DEBUG="-DDEBUG"
164 else
165 AC_MSG_RESULT([no])
166 fi,
167 AC_MSG_RESULT([no])
168)
169AC_SUBST(DEBUG)
170
171dnl Check whether to include natural language support (i18n)
172NLS=""
173AC_MSG_CHECKING([whether to include NLS support])
174AC_ARG_ENABLE(nls,
175 [ --enable-nls include natural language support [default=yes]],
176 if test x$enableval = "xyes"; then
177 AC_MSG_RESULT([yes])
178 NLS="-DNLS"
179 else
180 AC_MSG_RESULT([no])
181 fi,
182 AC_MSG_RESULT([yes])
183 NLS="-DNLS"
184)
185AC_SUBST(NLS)
186
187AC_CHECK_LIB(xpg4, setlocale, LIBS="$LIBS -lxpg4")
188
189AC_CHECK_PROGS(gencat_cmd, gencat)
190if test x$gencat_cmd = "x"; then
191 NLS=""
192fi
193
194
195dnl Check for new timed pixmap cache
196TIMEDCACHE=""
197AC_MSG_CHECKING([whether to use the new timed pixmap cache])
198AC_ARG_ENABLE(
199 timed-cache,
200[ --enable-timed-cache use new timed pixmap cache [default=yes]],
201 if test x$enableval = "xyes"; then
202 AC_MSG_RESULT([yes])
203 TIMEDCACHE="-DTIMEDCACHE"
204 else
205 AC_MSG_RESULT([no])
206 fi,
207 AC_MSG_RESULT([yes])
208 TIMEDCACHE="-DTIMEDCACHE"
209)
210AC_SUBST(TIMEDCACHE)
211
212dnl Check KDE
213KDE=""
214AC_MSG_CHECKING([whether to have KDE slit support])
215AC_ARG_ENABLE(
216 kde,
217[ --enable-kde KDE slit support [default=no]],
218 if test x$enableval = "xyes"; then
219 AC_MSG_RESULT([yes])
220 KDE="-DKDE"
221 else
222 AC_MSG_RESULT([no])
223 fi,
224 AC_MSG_RESULT([no])
225)
226AC_SUBST(KDE)
227
228dnl Check GNOME
229GNOME=""
230AC_MSG_CHECKING([whether to have GNOME support])
231AC_ARG_ENABLE(
232 gnome,
233[ --enable-gnome GNOME support [default=no] (DEVELOPMENT)],
234 if test x$enableval = "xyes"; then
235 AC_MSG_RESULT([yes])
236 GNOME="-DGNOME"
237 else
238 AC_MSG_RESULT([no])
239 fi,
240 AC_MSG_RESULT([no])
241)
242AC_SUBST(GNOME)
243
244dnl Determine the return type of signal handlers
245AC_TYPE_SIGNAL
246
247dnl Determine if maintainer portions of the Makefiles should be included.
248AM_MAINTAINER_MODE
249
250dnl Print results
251AC_MSG_RESULT([])
252AC_MSG_RESULT([ $PACKAGE version $VERSION configured successfully.])
253AC_MSG_RESULT([])
254AC_MSG_RESULT([Using '$prefix' for installation.])
255AC_MSG_RESULT([Using '$CXX' for C++ compiler.])
256AC_MSG_RESULT([Building with '$CXXFLAGS' for C++ compiler flags.])
257AC_MSG_RESULT([Building with '$LIBS' for linker flags.])
258AC_MSG_RESULT([])
259
260dnl Output files
261AM_CONFIG_HEADER(config.h)
262AC_OUTPUT(Makefile
263src/Makefile
264util/Makefile
265data/Makefile
266data/styles/Makefile
267doc/Makefile
268nls/Makefile
269nls/C/Makefile
270nls/da_DK/Makefile
271nls/es_ES/Makefile
272nls/et_EE/Makefile
273nls/fr_FR/Makefile
274nls/pt_BR/Makefile
275nls/ru_RU/Makefile
276nls/sv_SE/Makefile
277nls/tr_TR/Makefile
278nls/it_IT/Makefile
279version.h)