diff options
Diffstat (limited to 'configure.in')
-rw-r--r-- | configure.in | 207 |
1 files changed, 159 insertions, 48 deletions
diff --git a/configure.in b/configure.in index 7b58aa0..4ab70e3 100644 --- a/configure.in +++ b/configure.in | |||
@@ -1,7 +1,8 @@ | |||
1 | dnl configure.in for Fluxbox - created from configure.in Blackbox 0.61.1 | 1 | dnl configure.in for Fluxbox - created from configure.in Blackbox 0.61.1 |
2 | dnl Initialize autoconf and automake | 2 | dnl Initialize autoconf and automake |
3 | AC_INIT(src/main.cc) | 3 | AC_INIT(src/main.cc) |
4 | AM_INIT_AUTOMAKE(fluxbox,0.1.5,no-define) | 4 | AC_PREREQ(2.52) |
5 | AM_INIT_AUTOMAKE(fluxbox,0.9.2,no-define) | ||
5 | 6 | ||
6 | dnl Determine default prefix | 7 | dnl Determine default prefix |
7 | test x$prefix = "xNONE" && prefix="$ac_default_prefix" | 8 | test x$prefix = "xNONE" && prefix="$ac_default_prefix" |
@@ -10,8 +11,7 @@ dnl Check for various flavors of UNIX(r) | |||
10 | dnl AC_AIX | 11 | dnl AC_AIX |
11 | dnl AC_ISC_POSIX | 12 | dnl AC_ISC_POSIX |
12 | 13 | ||
13 | dnl TODO: do this | 14 | AC_LANG_CPLUSPLUS |
14 | dnl AC_LANG_CPLUSPLUS | ||
15 | 15 | ||
16 | dnl Locate required external software | 16 | dnl Locate required external software |
17 | AC_PROG_CC | 17 | AC_PROG_CC |
@@ -84,74 +84,72 @@ else | |||
84 | AC_MSG_RESULT([no]) | 84 | AC_MSG_RESULT([no]) |
85 | fi | 85 | fi |
86 | AC_SUBST(SHAPE) | 86 | AC_SUBST(SHAPE) |
87 | 87 | CXXFLAGS="$CXXFLAGS $SHAPE" | |
88 | LIBS="$LIBS $Xext_lib" | 88 | LIBS="$LIBS $Xext_lib" |
89 | 89 | ||
90 | dnl Check for the Slit | 90 | dnl Check for the Slit |
91 | SLIT="" | ||
92 | AC_MSG_CHECKING([whether to include the Slit]) | 91 | AC_MSG_CHECKING([whether to include the Slit]) |
93 | AC_ARG_ENABLE( | 92 | AC_ARG_ENABLE( |
94 | slit, [ --enable-slit include code for the Slit [default=yes]], | 93 | slit, [ --enable-slit include code for the Slit [default=yes]], |
95 | if test x$enableval = "xyes"; then | 94 | if test x$enableval = "xyes"; then |
96 | AC_MSG_RESULT([yes]) | 95 | AC_MSG_RESULT([yes]) |
97 | SLIT="-DSLIT" | 96 | AC_DEFINE(SLIT, 1, " compile with slit") |
98 | else | 97 | else |
99 | AC_MSG_RESULT([no]) | 98 | AC_MSG_RESULT([no]) |
100 | fi, | 99 | fi, |
101 | AC_MSG_RESULT([yes]) | 100 | AC_MSG_RESULT([yes]) |
102 | SLIT="-DSLIT" | 101 | AC_DEFINE(SLIT, 1, " compile with slit") |
103 | ) | 102 | ) |
104 | AC_SUBST(SLIT) | ||
105 | 103 | ||
106 | dnl Check for the new WM Spec | 104 | dnl Check for Remember options |
107 | NEWWMSPEC="" | 105 | AC_MSG_CHECKING([whether to include remember functionality]) |
108 | AC_MSG_CHECKING([whether to include the new WM Spec (DOES NOTHING)]) | ||
109 | AC_ARG_ENABLE( | 106 | AC_ARG_ENABLE( |
110 | newspec, | 107 | remember, [ --enable-remember include code for Remembering attributes [default=yes]], |
111 | [ --enable-newspec include code for the new WM Spec (DOES NOTHING) | ||
112 | [default=no]], | ||
113 | if test x$enableval = "xyes"; then | 108 | if test x$enableval = "xyes"; then |
114 | AC_MSG_RESULT([yes]) | 109 | AC_MSG_RESULT([yes]) |
115 | NEWWMSPEC="-DNEWWMSPEC" | 110 | AC_DEFINE(REMEMBER, 1, " compile with remember") |
111 | REMEMBER_SRC=true | ||
116 | else | 112 | else |
117 | AC_MSG_RESULT([no]) | 113 | AC_MSG_RESULT([no]) |
114 | REMEMBER_SRC=false | ||
118 | fi, | 115 | fi, |
119 | AC_MSG_RESULT([no]) | 116 | AC_MSG_RESULT([yes]) |
117 | AC_DEFINE(REMEMBER, 1, " compile with remember") | ||
118 | REMEMBER_SRC=true | ||
120 | ) | 119 | ) |
121 | AC_SUBST(NEWWMSPEC) | 120 | AM_CONDITIONAL(REMEMBER_SRC, test x$REMEMBER_SRC = xtrue) |
122 | 121 | ||
123 | 122 | AC_MSG_CHECKING([whether to include the new WM Spec]) | |
124 | dnl Check for Interlacing | ||
125 | INTERLACE="" | ||
126 | AC_MSG_CHECKING([whether to include interlacing image code]) | ||
127 | AC_ARG_ENABLE( | 123 | AC_ARG_ENABLE( |
128 | interlace, [ --enable-interlace include code for image interlacing [default=yes]], | 124 | newwmspec, |
125 | [ --enable-newwmspec include code for the new WM Spec [default=yes]], | ||
129 | if test x$enableval = "xyes"; then | 126 | if test x$enableval = "xyes"; then |
130 | AC_MSG_RESULT([yes]) | 127 | AC_MSG_RESULT([yes]) |
131 | INTERLACE="-DINTERLACE" | 128 | NEWWMSPEC=true |
129 | AC_DEFINE(USE_NEWWMSPEC, 1, " use extened window manager hints") | ||
132 | else | 130 | else |
133 | AC_MSG_RESULT([no]) | 131 | AC_MSG_RESULT([no]) |
132 | NEWWMSPEC=false | ||
134 | fi, | 133 | fi, |
135 | AC_MSG_RESULT([yes]) | 134 | AC_MSG_RESULT([yes]) |
136 | INTERLACE="-DINTERLACE" | 135 | AC_DEFINE(USE_NEWWMSPEC, 1, " use extened window manager hints") |
136 | NEWWMSPEC=true | ||
137 | ) | 137 | ) |
138 | AC_SUBST(INTERLACE) | 138 | AM_CONDITIONAL(NEWWMSPEC, test x$NEWWMSPEC = xtrue) |
139 | 139 | ||
140 | dnl Check for ordered 8bpp dithering | 140 | dnl Check for ordered 8bpp dithering |
141 | ORDEREDPSEUDO="" | ||
142 | AC_MSG_CHECKING([whether to include Pseudocolor ordered dithering code]) | 141 | AC_MSG_CHECKING([whether to include Pseudocolor ordered dithering code]) |
143 | AC_ARG_ENABLE(ordered-pseudo, | 142 | AC_ARG_ENABLE(ordered-pseudo, |
144 | [ --enable-ordered-pseudo include code for ordered pseudocolor (8bpp) | 143 | [ --enable-ordered-pseudo include code for ordered pseudocolor (8bpp) |
145 | dithering [default=no]], | 144 | dithering [default=no]], |
146 | if test x$enableval = "xyes"; then | 145 | if test x$enableval = "xyes"; then |
147 | AC_MSG_RESULT([yes]) | 146 | AC_MSG_RESULT([yes]) |
148 | ORDEREDPSEUDO="-DORDEREDPSEUDO" | 147 | AC_DEFINE(ORDEREDPSEUDO, 1, "ordered dithering code") |
149 | else | 148 | else |
150 | AC_MSG_RESULT([no]) | 149 | AC_MSG_RESULT([no]) |
151 | fi, | 150 | fi, |
152 | AC_MSG_RESULT([no]) | 151 | AC_MSG_RESULT([no]) |
153 | ) | 152 | ) |
154 | AC_SUBST(ORDEREDPSEUDO) | ||
155 | 153 | ||
156 | dnl Check whether to include debugging code | 154 | dnl Check whether to include debugging code |
157 | DEBUG="" | 155 | DEBUG="" |
@@ -160,29 +158,28 @@ AC_ARG_ENABLE(debug, | |||
160 | [ --enable-debug include verbose debugging code [default=no]], | 158 | [ --enable-debug include verbose debugging code [default=no]], |
161 | if test x$enableval = "xyes"; then | 159 | if test x$enableval = "xyes"; then |
162 | AC_MSG_RESULT([yes]) | 160 | AC_MSG_RESULT([yes]) |
163 | DEBUG="-DDEBUG" | 161 | DEBUG="-DDEBUG -fno-inline" |
164 | else | 162 | else |
165 | AC_MSG_RESULT([no]) | 163 | AC_MSG_RESULT([no]) |
166 | fi, | 164 | fi, |
167 | AC_MSG_RESULT([no]) | 165 | AC_MSG_RESULT([no]) |
168 | ) | 166 | ) |
169 | AC_SUBST(DEBUG) | 167 | AC_SUBST(DEBUG) |
168 | CXXFLAGS="$CXXFLAGS $DEBUG" | ||
170 | 169 | ||
171 | dnl Check whether to include natural language support (i18n) | 170 | dnl Check whether to include natural language support (i18n) |
172 | NLS="" | ||
173 | AC_MSG_CHECKING([whether to include NLS support]) | 171 | AC_MSG_CHECKING([whether to include NLS support]) |
174 | AC_ARG_ENABLE(nls, | 172 | AC_ARG_ENABLE(nls, |
175 | [ --enable-nls include natural language support [default=yes]], | 173 | [ --enable-nls include natural language support [default=yes]], |
176 | if test x$enableval = "xyes"; then | 174 | if test x$enableval = "xyes"; then |
177 | AC_MSG_RESULT([yes]) | 175 | AC_MSG_RESULT([yes]) |
178 | NLS="-DNLS" | 176 | AC_DEFINE(NLS, 1, "Natural language support") |
179 | else | 177 | else |
180 | AC_MSG_RESULT([no]) | 178 | AC_MSG_RESULT([no]) |
181 | fi, | 179 | fi, |
182 | AC_MSG_RESULT([yes]) | 180 | AC_MSG_RESULT([yes]) |
183 | NLS="-DNLS" | 181 | AC_DEFINE(NLS, 1, "Natural language support") |
184 | ) | 182 | ) |
185 | AC_SUBST(NLS) | ||
186 | 183 | ||
187 | AC_CHECK_LIB(xpg4, setlocale, LIBS="$LIBS -lxpg4") | 184 | AC_CHECK_LIB(xpg4, setlocale, LIBS="$LIBS -lxpg4") |
188 | 185 | ||
@@ -193,59 +190,164 @@ fi | |||
193 | 190 | ||
194 | 191 | ||
195 | dnl Check for new timed pixmap cache | 192 | dnl Check for new timed pixmap cache |
196 | TIMEDCACHE="" | ||
197 | AC_MSG_CHECKING([whether to use the new timed pixmap cache]) | 193 | AC_MSG_CHECKING([whether to use the new timed pixmap cache]) |
198 | AC_ARG_ENABLE( | 194 | AC_ARG_ENABLE( |
199 | timed-cache, | 195 | timed-cache, |
200 | [ --enable-timed-cache use new timed pixmap cache [default=yes]], | 196 | [ --enable-timed-cache use new timed pixmap cache [default=yes]], |
201 | if test x$enableval = "xyes"; then | 197 | if test x$enableval = "xyes"; then |
202 | AC_MSG_RESULT([yes]) | 198 | AC_MSG_RESULT([yes]) |
203 | TIMEDCACHE="-DTIMEDCACHE" | 199 | AC_DEFINE(TIMEDCACHE, 1, "timed cache") |
204 | else | 200 | else |
205 | AC_MSG_RESULT([no]) | 201 | AC_MSG_RESULT([no]) |
206 | fi, | 202 | fi, |
207 | AC_MSG_RESULT([yes]) | 203 | AC_MSG_RESULT([yes]) |
208 | TIMEDCACHE="-DTIMEDCACHE" | 204 | AC_DEFINE(TIMEDCACHE, 1, "timed cache") |
209 | ) | 205 | ) |
210 | AC_SUBST(TIMEDCACHE) | ||
211 | 206 | ||
212 | dnl Check KDE | 207 | dnl Check KDE |
213 | KDE="" | ||
214 | AC_MSG_CHECKING([whether to have KDE slit support]) | 208 | AC_MSG_CHECKING([whether to have KDE slit support]) |
215 | AC_ARG_ENABLE( | 209 | AC_ARG_ENABLE( |
216 | kde, | 210 | kde, |
217 | [ --enable-kde KDE slit support [default=no]], | 211 | [ --enable-kde KDE slit support [default=no]], |
218 | if test x$enableval = "xyes"; then | 212 | if test x$enableval = "xyes"; then |
219 | AC_MSG_RESULT([yes]) | 213 | AC_MSG_RESULT([yes]) |
220 | KDE="-DKDE" | 214 | AC_DEFINE(KDE, 1, "KDE slit support") |
221 | else | 215 | else |
222 | AC_MSG_RESULT([no]) | 216 | AC_MSG_RESULT([no]) |
223 | fi, | 217 | fi, |
224 | AC_MSG_RESULT([no]) | 218 | AC_MSG_RESULT([no]) |
225 | ) | 219 | ) |
226 | AC_SUBST(KDE) | ||
227 | 220 | ||
228 | dnl Check GNOME | 221 | dnl Check GNOME |
229 | GNOME="" | 222 | |
230 | AC_MSG_CHECKING([whether to have GNOME support]) | 223 | AC_MSG_CHECKING([whether to have GNOME support]) |
231 | AC_ARG_ENABLE( | 224 | AC_ARG_ENABLE( |
232 | gnome, | 225 | gnome, |
233 | [ --enable-gnome GNOME support [default=no] (DEVELOPMENT)], | 226 | [ --enable-gnome GNOME support [default=yes]], |
234 | if test x$enableval = "xyes"; then | 227 | if test x$enableval = "xyes"; then |
235 | AC_MSG_RESULT([yes]) | 228 | AC_MSG_RESULT([yes]) |
236 | GNOME="-DGNOME" | 229 | AC_DEFINE(USE_GNOME, 1, "Gnome 1 support") |
230 | GNOME=true | ||
237 | else | 231 | else |
238 | AC_MSG_RESULT([no]) | 232 | AC_MSG_RESULT([no]) |
233 | GNOME=false | ||
239 | fi, | 234 | fi, |
240 | AC_MSG_RESULT([no]) | 235 | AC_MSG_RESULT([yes]) |
236 | AC_DEFINE(USE_GNOME, 1, "Gnome 1 support") | ||
237 | GNOME=true | ||
238 | ) | ||
239 | AM_CONDITIONAL(GNOME, test x$GNOME = xtrue) | ||
240 | |||
241 | AC_MSG_CHECKING([whether to have Xft support]) | ||
242 | AM_PATH_XFT(yes, | ||
243 | XFT=true, | ||
244 | XFT=false | ||
245 | ) | ||
246 | |||
247 | if test "x$XFT" = "xtrue" ; then | ||
248 | AC_TRY_LINK([ | ||
249 | #include <X11/Xft/Xft.h> | ||
250 | ], [ XftFontClose(0, 0); return 1; ], | ||
251 | [ | ||
252 | |||
253 | AC_DEFINE(USE_XFT, 1, "antialias support") | ||
254 | AC_MSG_CHECKING([Xft UTF-8 support]) | ||
255 | AC_TRY_LINK([ | ||
256 | #include <X11/Xft/Xft.h> | ||
257 | ], [ XftDrawStringUtf8(0, 0, 0, 0, 0, 0, 0); return 0; ], | ||
258 | AC_DEFINE(HAVE_XFT_UTF8_STRING, 1, "Xft UTF8 support") | ||
259 | AC_MSG_RESULT(yes), | ||
260 | AC_MSG_RESULT(no) | ||
261 | ) | ||
262 | ], | ||
263 | [ AC_MSG_RESULT([Could not link with Xft. Install Xft if you want support for it.]) | ||
264 | XFT=false | ||
265 | ]) | ||
266 | fi | ||
267 | |||
268 | AM_CONDITIONAL(XFT, test x$XFT = xtrue) | ||
269 | |||
270 | AC_MSG_CHECKING([whether to have Xrender (transparent) support]) | ||
271 | AC_ARG_ENABLE( | ||
272 | xrender, | ||
273 | [ --enable-xrender Xrender (transparent) support [default=yes]], | ||
274 | if test x$enableval = "xyes"; then | ||
275 | AC_MSG_RESULT([yes]) | ||
276 | AC_CHECK_LIB(Xrender, XRenderCreatePicture, | ||
277 | AC_DEFINE(HAVE_XRENDER, 1, "Xrender support") | ||
278 | LIBS="$LIBS -lXrender") | ||
279 | else | ||
280 | AC_MSG_RESULT([no]) | ||
281 | fi, | ||
282 | AC_MSG_RESULT([yes]) | ||
283 | AC_CHECK_LIB(Xrender, XRenderCreatePicture, | ||
284 | AC_DEFINE(HAVE_XRENDER, 1, "Xrender support") | ||
285 | LIBS="$LIBS -lXrender") | ||
286 | ) | ||
287 | |||
288 | AC_MSG_CHECKING([whether to have Xpm (pixmap themes) support]) | ||
289 | AC_ARG_ENABLE( | ||
290 | xpm, | ||
291 | [ --enable-xpm Xpm (pixmap themes) support [default=yes]], | ||
292 | if test x$enableval = "xyes"; then | ||
293 | AC_MSG_RESULT([yes]) | ||
294 | AC_CHECK_LIB(Xpm, XpmReadFileToPixmap, | ||
295 | AC_DEFINE(HAVE_XPM, 1, "Xpm support") | ||
296 | LIBS="$LIBS -lXpm") | ||
297 | else | ||
298 | AC_MSG_RESULT([no]) | ||
299 | fi, | ||
300 | AC_MSG_RESULT([yes]) | ||
301 | AC_CHECK_LIB(Xpm, XpmReadFileToPixmap, | ||
302 | AC_DEFINE(HAVE_XPM, 1, "Xpm support") | ||
303 | LIBS="$LIBS -lXpm") | ||
304 | ) | ||
305 | |||
306 | |||
307 | |||
308 | |||
309 | |||
310 | AC_MSG_CHECKING([whether to have Xmb (multibyte font, utf-8) support]) | ||
311 | AC_ARG_ENABLE( | ||
312 | xmb, | ||
313 | [ --enable-xmb Xmb (multibyte font, utf-8) support [default=yes]], | ||
314 | if test x$enableval = "xyes"; then | ||
315 | AC_MSG_RESULT([yes]) | ||
316 | AC_DEFINE(USE_XMB, 1, "multibyte support") | ||
317 | MULTIBYTE=true | ||
318 | else | ||
319 | AC_MSG_RESULT([no]) | ||
320 | MULTIBYTE=false | ||
321 | fi, | ||
322 | AC_MSG_RESULT([yes]) | ||
323 | AC_DEFINE(USE_XMB, 1, "multibyte support") | ||
324 | MULTIBYTE=true | ||
241 | ) | 325 | ) |
242 | AC_SUBST(GNOME) | 326 | AM_CONDITIONAL(MULTIBYTE, test x$MULTIBYTE = xtrue) |
327 | |||
328 | dnl Check for Xinerama support | ||
329 | |||
330 | AC_MSG_CHECKING([whether to build support for the Xinerama extension]) | ||
331 | AC_ARG_ENABLE(xinerama, | ||
332 | [ --enable-xinerama enable xinerama extension [default=no]], , [enable_xinerama=no]) | ||
333 | |||
334 | if test "x$enable_xinerama" = "xyes"; then | ||
335 | AC_MSG_RESULT([yes]) | ||
336 | AC_CHECK_LIB(Xinerama, XineramaQueryScreens, | ||
337 | XINERAMA="-DXINERAMA"; Xinerama_libs="-lXinerama", ) | ||
338 | else | ||
339 | AC_MSG_RESULT([no]) | ||
340 | fi | ||
341 | AC_SUBST(XINERAMA) | ||
342 | CXXFLAGS="$CXXFLAGS $XINERAMA" | ||
343 | |||
344 | LIBS="$LIBS $Xinerama_libs" | ||
243 | 345 | ||
244 | dnl Determine the return type of signal handlers | 346 | dnl Determine the return type of signal handlers |
245 | AC_TYPE_SIGNAL | 347 | AC_TYPE_SIGNAL |
246 | 348 | ||
247 | dnl Determine if maintainer portions of the Makefiles should be included. | 349 | dnl Determine if maintainer portions of the Makefiles should be included. |
248 | AM_MAINTAINER_MODE | 350 | dnl AM_MAINTAINER_MODE |
249 | 351 | ||
250 | dnl Print results | 352 | dnl Print results |
251 | AC_MSG_RESULT([]) | 353 | AC_MSG_RESULT([]) |
@@ -259,9 +361,13 @@ AC_MSG_RESULT([]) | |||
259 | 361 | ||
260 | dnl Output files | 362 | dnl Output files |
261 | AM_CONFIG_HEADER(config.h) | 363 | AM_CONFIG_HEADER(config.h) |
364 | |||
262 | AC_OUTPUT(Makefile | 365 | AC_OUTPUT(Makefile |
366 | version.h | ||
263 | src/Makefile | 367 | src/Makefile |
368 | src/FbTk/Makefile | ||
264 | util/Makefile | 369 | util/Makefile |
370 | util/fbrun/Makefile | ||
265 | data/Makefile | 371 | data/Makefile |
266 | data/styles/Makefile | 372 | data/styles/Makefile |
267 | doc/Makefile | 373 | doc/Makefile |
@@ -275,5 +381,10 @@ nls/pt_BR/Makefile | |||
275 | nls/ru_RU/Makefile | 381 | nls/ru_RU/Makefile |
276 | nls/sv_SE/Makefile | 382 | nls/sv_SE/Makefile |
277 | nls/tr_TR/Makefile | 383 | nls/tr_TR/Makefile |
384 | nls/pt_PT/Makefile | ||
385 | nls/bg_BG/Makefile | ||
386 | nls/ja_JP/Makefile | ||
387 | nls/lv_LV/Makefile | ||
278 | nls/it_IT/Makefile | 388 | nls/it_IT/Makefile |
279 | version.h) | 389 | nls/de_DE/Makefile |
390 | ) | ||