diff options
Diffstat (limited to 'configure.in')
-rw-r--r-- | configure.in | 43 |
1 files changed, 23 insertions, 20 deletions
diff --git a/configure.in b/configure.in index 16e9e23..d3f0f07 100644 --- a/configure.in +++ b/configure.in | |||
@@ -181,7 +181,7 @@ dnl Check for XShape extension support and proper library files. | |||
181 | SHAPE="" | 181 | SHAPE="" |
182 | AC_MSG_CHECKING([whether to build support for the XShape extension]) | 182 | AC_MSG_CHECKING([whether to build support for the XShape extension]) |
183 | AC_ARG_ENABLE( | 183 | AC_ARG_ENABLE( |
184 | shape, [ --enable-shape enable support of the XShape extension [default=yes]]) | 184 | shape, [ --enable-shape enable support of the XShape extension ([default=yes])]) |
185 | 185 | ||
186 | : ${enableval="yes"} | 186 | : ${enableval="yes"} |
187 | if test x$enableval = "xyes"; then | 187 | if test x$enableval = "xyes"; then |
@@ -208,7 +208,7 @@ LIBS="$LIBS $Xext_lib" | |||
208 | dnl Check for the Slit | 208 | dnl Check for the Slit |
209 | AC_MSG_CHECKING([whether to include the Slit]) | 209 | AC_MSG_CHECKING([whether to include the Slit]) |
210 | AC_ARG_ENABLE( | 210 | AC_ARG_ENABLE( |
211 | slit, [ --enable-slit include code for the Slit [default=yes]], | 211 | slit, [ --enable-slit include code for the Slit ([default=yes])], |
212 | if test x$enableval = "xyes"; then | 212 | if test x$enableval = "xyes"; then |
213 | AC_MSG_RESULT([yes]) | 213 | AC_MSG_RESULT([yes]) |
214 | AC_DEFINE(SLIT, 1, " compile with slit") | 214 | AC_DEFINE(SLIT, 1, " compile with slit") |
@@ -222,7 +222,7 @@ AC_ARG_ENABLE( | |||
222 | dnl Check for Remember options | 222 | dnl Check for Remember options |
223 | AC_MSG_CHECKING([whether to include remember functionality]) | 223 | AC_MSG_CHECKING([whether to include remember functionality]) |
224 | AC_ARG_ENABLE( | 224 | AC_ARG_ENABLE( |
225 | remember, [ --enable-remember include code for Remembering attributes [default=yes]], | 225 | remember, [ --enable-remember include code for Remembering attributes ([default=yes])], |
226 | if test x$enableval = "xyes"; then | 226 | if test x$enableval = "xyes"; then |
227 | AC_MSG_RESULT([yes]) | 227 | AC_MSG_RESULT([yes]) |
228 | AC_DEFINE(REMEMBER, 1, " compile with remember") | 228 | AC_DEFINE(REMEMBER, 1, " compile with remember") |
@@ -240,7 +240,7 @@ AM_CONDITIONAL(REMEMBER_SRC, test x$REMEMBER_SRC = xtrue) | |||
240 | dnl Check for Toolbar options | 240 | dnl Check for Toolbar options |
241 | AC_MSG_CHECKING([whether to include Toolbar]) | 241 | AC_MSG_CHECKING([whether to include Toolbar]) |
242 | AC_ARG_ENABLE( | 242 | AC_ARG_ENABLE( |
243 | toolbar, [ --enable-toolbar include code for Toolbar [default=yes]], | 243 | toolbar, [ --enable-toolbar include code for Toolbar ([default=yes])], |
244 | if test x$enableval = "xyes"; then | 244 | if test x$enableval = "xyes"; then |
245 | AC_MSG_RESULT([yes]) | 245 | AC_MSG_RESULT([yes]) |
246 | AC_DEFINE(USE_TOOLBAR, 1, " compile with toolbar") | 246 | AC_DEFINE(USE_TOOLBAR, 1, " compile with toolbar") |
@@ -258,7 +258,7 @@ AM_CONDITIONAL(TOOLBAR_SRC, test x$TOOLBAR_SRC = xtrue) | |||
258 | AC_MSG_CHECKING([whether to have (POSIX) regular expression support]) | 258 | AC_MSG_CHECKING([whether to have (POSIX) regular expression support]) |
259 | AC_ARG_ENABLE( | 259 | AC_ARG_ENABLE( |
260 | regexp, | 260 | regexp, |
261 | [ --enable-regexp regular expression support [default=yes]], | 261 | [ --enable-regexp regular expression support ([default=yes])], |
262 | if test x$enableval = "xyes"; then | 262 | if test x$enableval = "xyes"; then |
263 | AC_EGREP_HEADER([regex_t],regex.h, | 263 | AC_EGREP_HEADER([regex_t],regex.h, |
264 | AC_DEFINE(USE_REGEXP, 1, "Regular Expression support") | 264 | AC_DEFINE(USE_REGEXP, 1, "Regular Expression support") |
@@ -284,7 +284,7 @@ AM_CONDITIONAL(REGEXP_SRC, test x$REGEXP_SRC = xtrue) | |||
284 | AC_MSG_CHECKING([whether to include the new WM Spec]) | 284 | AC_MSG_CHECKING([whether to include the new WM Spec]) |
285 | AC_ARG_ENABLE( | 285 | AC_ARG_ENABLE( |
286 | newwmspec, | 286 | newwmspec, |
287 | [ --enable-newwmspec include code for the new WM Spec [default=yes]], | 287 | [ --enable-newwmspec include code for the new WM Spec ([default=yes])], |
288 | if test x$enableval = "xyes"; then | 288 | if test x$enableval = "xyes"; then |
289 | AC_MSG_RESULT([yes]) | 289 | AC_MSG_RESULT([yes]) |
290 | NEWWMSPEC=true | 290 | NEWWMSPEC=true |
@@ -303,7 +303,7 @@ dnl Check for ordered 8bpp dithering | |||
303 | AC_MSG_CHECKING([whether to include Pseudocolor ordered dithering code]) | 303 | AC_MSG_CHECKING([whether to include Pseudocolor ordered dithering code]) |
304 | AC_ARG_ENABLE(ordered-pseudo, | 304 | AC_ARG_ENABLE(ordered-pseudo, |
305 | [ --enable-ordered-pseudo include code for ordered pseudocolor (8bpp) | 305 | [ --enable-ordered-pseudo include code for ordered pseudocolor (8bpp) |
306 | dithering [default=no]], | 306 | dithering ([default=no])], |
307 | if test x$enableval = "xyes"; then | 307 | if test x$enableval = "xyes"; then |
308 | AC_MSG_RESULT([yes]) | 308 | AC_MSG_RESULT([yes]) |
309 | AC_DEFINE(ORDEREDPSEUDO, 1, "ordered dithering code") | 309 | AC_DEFINE(ORDEREDPSEUDO, 1, "ordered dithering code") |
@@ -317,7 +317,7 @@ dnl Check whether to include debugging code | |||
317 | DEBUG="" | 317 | DEBUG="" |
318 | AC_MSG_CHECKING([whether to include verbose debugging code]) | 318 | AC_MSG_CHECKING([whether to include verbose debugging code]) |
319 | AC_ARG_ENABLE(debug, | 319 | AC_ARG_ENABLE(debug, |
320 | [ --enable-debug include verbose debugging code [default=no]], | 320 | [ --enable-debug include verbose debugging code ([default=no])], |
321 | if test x$enableval = "xyes"; then | 321 | if test x$enableval = "xyes"; then |
322 | AC_MSG_RESULT([yes]) | 322 | AC_MSG_RESULT([yes]) |
323 | DEBUG="-DDEBUG -Wall" | 323 | DEBUG="-DDEBUG -Wall" |
@@ -332,7 +332,7 @@ CXXFLAGS="$CXXFLAGS $DEBUG" | |||
332 | dnl Check whether to include native language support (i18n) | 332 | dnl Check whether to include native language support (i18n) |
333 | AC_MSG_CHECKING([whether to include NLS support]) | 333 | AC_MSG_CHECKING([whether to include NLS support]) |
334 | AC_ARG_ENABLE(nls, | 334 | AC_ARG_ENABLE(nls, |
335 | [ --enable-nls include native language support [default=no]], | 335 | [ --enable-nls include native language support ([default=no])], |
336 | if test x$enableval = "xyes"; then | 336 | if test x$enableval = "xyes"; then |
337 | AC_MSG_RESULT([yes]) | 337 | AC_MSG_RESULT([yes]) |
338 | AC_DEFINE(NLS, 1, "Native language support") | 338 | AC_DEFINE(NLS, 1, "Native language support") |
@@ -353,7 +353,7 @@ dnl Check for new timed pixmap cache | |||
353 | AC_MSG_CHECKING([whether to use the new timed pixmap cache]) | 353 | AC_MSG_CHECKING([whether to use the new timed pixmap cache]) |
354 | AC_ARG_ENABLE( | 354 | AC_ARG_ENABLE( |
355 | timed-cache, | 355 | timed-cache, |
356 | [ --enable-timed-cache use new timed pixmap cache [default=yes]], | 356 | [ --enable-timed-cache use new timed pixmap cache ([default=yes])], |
357 | if test x$enableval = "xyes"; then | 357 | if test x$enableval = "xyes"; then |
358 | AC_MSG_RESULT([yes]) | 358 | AC_MSG_RESULT([yes]) |
359 | AC_DEFINE(TIMEDCACHE, 1, "timed cache") | 359 | AC_DEFINE(TIMEDCACHE, 1, "timed cache") |
@@ -368,7 +368,7 @@ dnl Check KDE | |||
368 | AC_MSG_CHECKING([whether to have KDE slit support]) | 368 | AC_MSG_CHECKING([whether to have KDE slit support]) |
369 | AC_ARG_ENABLE( | 369 | AC_ARG_ENABLE( |
370 | kde, | 370 | kde, |
371 | [ --enable-kde KDE slit support [default=yes]], | 371 | [ --enable-kde KDE slit support ([default=yes])], |
372 | if test x$enableval = "xyes"; then | 372 | if test x$enableval = "xyes"; then |
373 | AC_MSG_RESULT([yes]) | 373 | AC_MSG_RESULT([yes]) |
374 | AC_DEFINE(KDE, 1, "KDE slit support") | 374 | AC_DEFINE(KDE, 1, "KDE slit support") |
@@ -385,7 +385,7 @@ dnl Check GNOME | |||
385 | AC_MSG_CHECKING([whether to have GNOME support]) | 385 | AC_MSG_CHECKING([whether to have GNOME support]) |
386 | AC_ARG_ENABLE( | 386 | AC_ARG_ENABLE( |
387 | gnome, | 387 | gnome, |
388 | [ --enable-gnome GNOME support [default=yes]], | 388 | [ --enable-gnome GNOME support ([default=yes])], |
389 | if test x$enableval = "xyes"; then | 389 | if test x$enableval = "xyes"; then |
390 | AC_MSG_RESULT([yes]) | 390 | AC_MSG_RESULT([yes]) |
391 | AC_DEFINE(USE_GNOME, 1, "Gnome 1 support") | 391 | AC_DEFINE(USE_GNOME, 1, "Gnome 1 support") |
@@ -432,7 +432,7 @@ AM_CONDITIONAL(XFT, test x$XFT = xtrue) | |||
432 | AC_MSG_CHECKING([whether to have Xrender (transparent) support]) | 432 | AC_MSG_CHECKING([whether to have Xrender (transparent) support]) |
433 | AC_ARG_ENABLE( | 433 | AC_ARG_ENABLE( |
434 | xrender, | 434 | xrender, |
435 | [ --enable-xrender Xrender (transparent) support [default=yes]], | 435 | [ --enable-xrender Xrender (transparent) support ([default=yes])], |
436 | if test x$enableval = "xyes"; then | 436 | if test x$enableval = "xyes"; then |
437 | AC_MSG_RESULT([yes]) | 437 | AC_MSG_RESULT([yes]) |
438 | AC_CHECK_LIB(Xrender, XRenderCreatePicture, | 438 | AC_CHECK_LIB(Xrender, XRenderCreatePicture, |
@@ -451,7 +451,7 @@ XPM=false | |||
451 | AC_MSG_CHECKING([whether to have Xpm (pixmap themes) support]) | 451 | AC_MSG_CHECKING([whether to have Xpm (pixmap themes) support]) |
452 | AC_ARG_ENABLE( | 452 | AC_ARG_ENABLE( |
453 | xpm, | 453 | xpm, |
454 | [ --enable-xpm Xpm (pixmap themes) support [default=yes]], | 454 | [ --enable-xpm Xpm (pixmap themes) support ([default=yes])], |
455 | if test x$enableval = "xyes"; then | 455 | if test x$enableval = "xyes"; then |
456 | AC_MSG_RESULT([yes]) | 456 | AC_MSG_RESULT([yes]) |
457 | AC_CHECK_LIB(Xpm, XpmReadFileToPixmap, | 457 | AC_CHECK_LIB(Xpm, XpmReadFileToPixmap, |
@@ -475,8 +475,8 @@ IMLIB2=false | |||
475 | AC_MSG_CHECKING([whether to have Imlib2 (pixmap themes) support]) | 475 | AC_MSG_CHECKING([whether to have Imlib2 (pixmap themes) support]) |
476 | AC_ARG_ENABLE(imlib2, | 476 | AC_ARG_ENABLE(imlib2, |
477 | AC_HELP_STRING([--enable-imlib2], | 477 | AC_HELP_STRING([--enable-imlib2], |
478 | [Imlib2 (pixmap themes) support [default=no]]), , | 478 | [Imlib2 (pixmap themes) support ([default=yes])]), , |
479 | [enable_imlib2=no]) | 479 | [enable_imlib2=yes]) |
480 | if test x$enable_imlib2 = "xyes"; then | 480 | if test x$enable_imlib2 = "xyes"; then |
481 | AC_MSG_RESULT([yes]) | 481 | AC_MSG_RESULT([yes]) |
482 | AC_PATH_GENERIC(imlib2, 1.0.0, | 482 | AC_PATH_GENERIC(imlib2, 1.0.0, |
@@ -500,7 +500,7 @@ AM_CONDITIONAL(IMLIB2, test x$IMLIB2 = xtrue) | |||
500 | AC_MSG_CHECKING([whether to have Xmb (multibyte font, utf-8) support]) | 500 | AC_MSG_CHECKING([whether to have Xmb (multibyte font, utf-8) support]) |
501 | AC_ARG_ENABLE( | 501 | AC_ARG_ENABLE( |
502 | xmb, | 502 | xmb, |
503 | [ --enable-xmb Xmb (multibyte font, utf-8) support [default=yes]], | 503 | [ --enable-xmb Xmb (multibyte font, utf-8) support ([default=yes])], |
504 | if test x$enableval = "xyes"; then | 504 | if test x$enableval = "xyes"; then |
505 | AC_MSG_RESULT([yes]) | 505 | AC_MSG_RESULT([yes]) |
506 | AC_DEFINE(USE_XMB, 1, "multibyte support") | 506 | AC_DEFINE(USE_XMB, 1, "multibyte support") |
@@ -518,7 +518,7 @@ AM_CONDITIONAL(MULTIBYTE, test x$MULTIBYTE = xtrue) | |||
518 | AC_MSG_CHECKING([whether to have RANDR (The X Resize and Rotate Extension) support]) | 518 | AC_MSG_CHECKING([whether to have RANDR (The X Resize and Rotate Extension) support]) |
519 | AC_ARG_ENABLE( | 519 | AC_ARG_ENABLE( |
520 | randr, | 520 | randr, |
521 | [ --enable-randr RANDR (The X Resize and Rotate Extension) support [default=yes]], | 521 | [ --enable-randr RANDR (The X Resize and Rotate Extension) support ([default=yes])], |
522 | if test x$enableval = "xyes"; then | 522 | if test x$enableval = "xyes"; then |
523 | AC_MSG_RESULT([yes]) | 523 | AC_MSG_RESULT([yes]) |
524 | AC_CHECK_LIB(Xrandr, XRRQueryExtension, | 524 | AC_CHECK_LIB(Xrandr, XRRQueryExtension, |
@@ -538,7 +538,7 @@ dnl Check for Xinerama support | |||
538 | AC_MSG_CHECKING([whether to build support for the Xinerama extension]) | 538 | AC_MSG_CHECKING([whether to build support for the Xinerama extension]) |
539 | AC_ARG_ENABLE( | 539 | AC_ARG_ENABLE( |
540 | xinerama, | 540 | xinerama, |
541 | [ --enable-xinerama enable xinerama extension [default=no]], | 541 | [ --enable-xinerama enable xinerama extension ([default=yes])], |
542 | if test x$enableval = "xyes"; then | 542 | if test x$enableval = "xyes"; then |
543 | AC_MSG_RESULT([yes]) | 543 | AC_MSG_RESULT([yes]) |
544 | AC_CHECK_LIB(Xinerama, XineramaQueryScreens, | 544 | AC_CHECK_LIB(Xinerama, XineramaQueryScreens, |
@@ -548,7 +548,10 @@ AC_ARG_ENABLE( | |||
548 | AC_MSG_RESULT([no]) | 548 | AC_MSG_RESULT([no]) |
549 | fi, | 549 | fi, |
550 | 550 | ||
551 | AC_MSG_RESULT([no]) | 551 | AC_MSG_RESULT([yes]) |
552 | AC_CHECK_LIB(Xinerama, XineramaQueryScreens, | ||
553 | AC_DEFINE(XINERAMA, 1, "Xinerama support") | ||
554 | LIBS="$LIBS -lXinerama") | ||
552 | ) | 555 | ) |
553 | 556 | ||
554 | AC_ARG_WITH( | 557 | AC_ARG_WITH( |