diff options
Diffstat (limited to 'configure.in')
-rw-r--r-- | configure.in | 58 |
1 files changed, 20 insertions, 38 deletions
diff --git a/configure.in b/configure.in index c9e07ac..5c41b0e 100644 --- a/configure.in +++ b/configure.in | |||
@@ -87,24 +87,21 @@ CXXFLAGS="$CXXFLAGS $SHAPE" | |||
87 | LIBS="$LIBS $Xext_lib" | 87 | LIBS="$LIBS $Xext_lib" |
88 | 88 | ||
89 | dnl Check for the Slit | 89 | dnl Check for the Slit |
90 | SLIT="" | ||
91 | AC_MSG_CHECKING([whether to include the Slit]) | 90 | AC_MSG_CHECKING([whether to include the Slit]) |
92 | AC_ARG_ENABLE( | 91 | AC_ARG_ENABLE( |
93 | slit, [ --enable-slit include code for the Slit [default=yes]], | 92 | slit, [ --enable-slit include code for the Slit [default=yes]], |
94 | if test x$enableval = "xyes"; then | 93 | if test x$enableval = "xyes"; then |
95 | AC_MSG_RESULT([yes]) | 94 | AC_MSG_RESULT([yes]) |
96 | SLIT="-DSLIT" | 95 | AC_DEFINE(SLIT, 1, " compile with slit") |
97 | else | 96 | else |
98 | AC_MSG_RESULT([no]) | 97 | AC_MSG_RESULT([no]) |
99 | fi, | 98 | fi, |
100 | AC_MSG_RESULT([yes]) | 99 | AC_MSG_RESULT([yes]) |
101 | SLIT="-DSLIT" | 100 | AC_DEFINE(SLIT, 1, " compile with slit") |
102 | ) | 101 | ) |
103 | AC_SUBST(SLIT) | 102 | |
104 | CXXFLAGS="$CXXFLAGS $SLIT" | ||
105 | 103 | ||
106 | dnl Check for the new WM Spec | 104 | dnl Check for the new WM Spec |
107 | NEWWMSPEC="" | ||
108 | AC_MSG_CHECKING([whether to include the new WM Spec (DOES NOTHING)]) | 105 | AC_MSG_CHECKING([whether to include the new WM Spec (DOES NOTHING)]) |
109 | AC_ARG_ENABLE( | 106 | AC_ARG_ENABLE( |
110 | newspec, | 107 | newspec, |
@@ -112,48 +109,42 @@ AC_ARG_ENABLE( | |||
112 | [default=no]], | 109 | [default=no]], |
113 | if test x$enableval = "xyes"; then | 110 | if test x$enableval = "xyes"; then |
114 | AC_MSG_RESULT([yes]) | 111 | AC_MSG_RESULT([yes]) |
115 | NEWWMSPEC="-DNEWWMSPEC" | 112 | AC_DEFINE(NEWWMSPEC, 1, "Extended Window Manager Hints") |
116 | else | 113 | else |
117 | AC_MSG_RESULT([no]) | 114 | AC_MSG_RESULT([no]) |
118 | fi, | 115 | fi, |
119 | AC_MSG_RESULT([no]) | 116 | AC_MSG_RESULT([no]) |
120 | ) | 117 | ) |
121 | AC_SUBST(NEWWMSPEC) | 118 | |
122 | CXXFLAGS="$CXXFLAGS $NEWWMSPEC" | ||
123 | 119 | ||
124 | dnl Check for Interlacing | 120 | dnl Check for Interlacing |
125 | INTERLACE="" | ||
126 | AC_MSG_CHECKING([whether to include interlacing image code]) | 121 | AC_MSG_CHECKING([whether to include interlacing image code]) |
127 | AC_ARG_ENABLE( | 122 | AC_ARG_ENABLE( |
128 | interlace, [ --enable-interlace include code for image interlacing [default=yes]], | 123 | interlace, [ --enable-interlace include code for image interlacing [default=yes]], |
129 | if test x$enableval = "xyes"; then | 124 | if test x$enableval = "xyes"; then |
130 | AC_MSG_RESULT([yes]) | 125 | AC_MSG_RESULT([yes]) |
131 | INTERLACE="-DINTERLACE" | 126 | AC_DEFINE(INTERLACE, 1, "Interlaced rendering") |
132 | else | 127 | else |
133 | AC_MSG_RESULT([no]) | 128 | AC_MSG_RESULT([no]) |
134 | fi, | 129 | fi, |
135 | AC_MSG_RESULT([yes]) | 130 | AC_MSG_RESULT([yes]) |
136 | INTERLACE="-DINTERLACE" | 131 | AC_DEFINE(INTERLACE, 1, "Interlaced rendering") |
137 | ) | 132 | ) |
138 | AC_SUBST(INTERLACE) | 133 | |
139 | CXXFLAGS="$CXXFLAGS $INTERLACE" | ||
140 | 134 | ||
141 | dnl Check for ordered 8bpp dithering | 135 | dnl Check for ordered 8bpp dithering |
142 | ORDEREDPSEUDO="" | ||
143 | AC_MSG_CHECKING([whether to include Pseudocolor ordered dithering code]) | 136 | AC_MSG_CHECKING([whether to include Pseudocolor ordered dithering code]) |
144 | AC_ARG_ENABLE(ordered-pseudo, | 137 | AC_ARG_ENABLE(ordered-pseudo, |
145 | [ --enable-ordered-pseudo include code for ordered pseudocolor (8bpp) | 138 | [ --enable-ordered-pseudo include code for ordered pseudocolor (8bpp) |
146 | dithering [default=no]], | 139 | dithering [default=no]], |
147 | if test x$enableval = "xyes"; then | 140 | if test x$enableval = "xyes"; then |
148 | AC_MSG_RESULT([yes]) | 141 | AC_MSG_RESULT([yes]) |
149 | ORDEREDPSEUDO="-DORDEREDPSEUDO" | 142 | AC_DEFINE(ORDEREDPSEUDO, 1, "ordered dithering code") |
150 | else | 143 | else |
151 | AC_MSG_RESULT([no]) | 144 | AC_MSG_RESULT([no]) |
152 | fi, | 145 | fi, |
153 | AC_MSG_RESULT([no]) | 146 | AC_MSG_RESULT([no]) |
154 | ) | 147 | ) |
155 | AC_SUBST(ORDEREDPSEUDO) | ||
156 | CXXFLAGS="$CXXFLAGS $ORDEREDPSEUDO" | ||
157 | 148 | ||
158 | dnl Check whether to include debugging code | 149 | dnl Check whether to include debugging code |
159 | DEBUG="" | 150 | DEBUG="" |
@@ -172,21 +163,18 @@ AC_SUBST(DEBUG) | |||
172 | CXXFLAGS="$CXXFLAGS $DEBUG" | 163 | CXXFLAGS="$CXXFLAGS $DEBUG" |
173 | 164 | ||
174 | dnl Check whether to include natural language support (i18n) | 165 | dnl Check whether to include natural language support (i18n) |
175 | NLS="" | ||
176 | AC_MSG_CHECKING([whether to include NLS support]) | 166 | AC_MSG_CHECKING([whether to include NLS support]) |
177 | AC_ARG_ENABLE(nls, | 167 | AC_ARG_ENABLE(nls, |
178 | [ --enable-nls include natural language support [default=yes]], | 168 | [ --enable-nls include natural language support [default=yes]], |
179 | if test x$enableval = "xyes"; then | 169 | if test x$enableval = "xyes"; then |
180 | AC_MSG_RESULT([yes]) | 170 | AC_MSG_RESULT([yes]) |
181 | NLS="-DNLS" | 171 | AC_DEFINE(NLS, 1, "Natural language support") |
182 | else | 172 | else |
183 | AC_MSG_RESULT([no]) | 173 | AC_MSG_RESULT([no]) |
184 | fi, | 174 | fi, |
185 | AC_MSG_RESULT([yes]) | 175 | AC_MSG_RESULT([yes]) |
186 | NLS="-DNLS" | 176 | AC_DEFINE(NLS, 1, "Natural language support") |
187 | ) | 177 | ) |
188 | AC_SUBST(NLS) | ||
189 | CXXFLAGS="$CXXFLAGS $NLS" | ||
190 | 178 | ||
191 | AC_CHECK_LIB(xpg4, setlocale, LIBS="$LIBS -lxpg4") | 179 | AC_CHECK_LIB(xpg4, setlocale, LIBS="$LIBS -lxpg4") |
192 | 180 | ||
@@ -197,59 +185,51 @@ fi | |||
197 | 185 | ||
198 | 186 | ||
199 | dnl Check for new timed pixmap cache | 187 | dnl Check for new timed pixmap cache |
200 | TIMEDCACHE="" | ||
201 | AC_MSG_CHECKING([whether to use the new timed pixmap cache]) | 188 | AC_MSG_CHECKING([whether to use the new timed pixmap cache]) |
202 | AC_ARG_ENABLE( | 189 | AC_ARG_ENABLE( |
203 | timed-cache, | 190 | timed-cache, |
204 | [ --enable-timed-cache use new timed pixmap cache [default=yes]], | 191 | [ --enable-timed-cache use new timed pixmap cache [default=yes]], |
205 | if test x$enableval = "xyes"; then | 192 | if test x$enableval = "xyes"; then |
206 | AC_MSG_RESULT([yes]) | 193 | AC_MSG_RESULT([yes]) |
207 | TIMEDCACHE="-DTIMEDCACHE" | 194 | AC_DEFINE(TIMEDCACHE, 1, "timed cache") |
208 | else | 195 | else |
209 | AC_MSG_RESULT([no]) | 196 | AC_MSG_RESULT([no]) |
210 | fi, | 197 | fi, |
211 | AC_MSG_RESULT([yes]) | 198 | AC_MSG_RESULT([yes]) |
212 | TIMEDCACHE="-DTIMEDCACHE" | 199 | AC_DEFINE(TIMEDCACHE, 1, "timed cache") |
213 | ) | 200 | ) |
214 | AC_SUBST(TIMEDCACHE) | ||
215 | CXXFLAGS="$CXXFLAGS $TIMEDCACHE" | ||
216 | 201 | ||
217 | dnl Check KDE | 202 | dnl Check KDE |
218 | KDE="" | ||
219 | AC_MSG_CHECKING([whether to have KDE slit support]) | 203 | AC_MSG_CHECKING([whether to have KDE slit support]) |
220 | AC_ARG_ENABLE( | 204 | AC_ARG_ENABLE( |
221 | kde, | 205 | kde, |
222 | [ --enable-kde KDE slit support [default=no]], | 206 | [ --enable-kde KDE slit support [default=no]], |
223 | if test x$enableval = "xyes"; then | 207 | if test x$enableval = "xyes"; then |
224 | AC_MSG_RESULT([yes]) | 208 | AC_MSG_RESULT([yes]) |
225 | KDE="-DKDE" | 209 | AC_DEFINE(KDE, 1, "KDE slit support") |
226 | else | 210 | else |
227 | AC_MSG_RESULT([no]) | 211 | AC_MSG_RESULT([no]) |
228 | fi, | 212 | fi, |
229 | AC_MSG_RESULT([no]) | 213 | AC_MSG_RESULT([no]) |
230 | ) | 214 | ) |
231 | AC_SUBST(KDE) | ||
232 | CXXFLAGS="$CXXFLAGS $KDE" | ||
233 | 215 | ||
234 | dnl Check GNOME | 216 | dnl Check GNOME |
235 | GNOME="" | 217 | |
236 | AC_MSG_CHECKING([whether to have GNOME support]) | 218 | AC_MSG_CHECKING([whether to have GNOME support]) |
237 | AC_ARG_ENABLE( | 219 | AC_ARG_ENABLE( |
238 | gnome, | 220 | gnome, |
239 | [ --enable-gnome GNOME support [default=no]], | 221 | [ --enable-gnome GNOME support [default=no]], |
240 | if test x$enableval = "xyes"; then | 222 | if test x$enableval = "xyes"; then |
241 | AC_MSG_RESULT([yes]) | 223 | AC_MSG_RESULT([yes]) |
242 | GNOME="-DGNOME" | 224 | AC_DEFINE(GNOME, 1, "Gnome 1 support") |
243 | else | 225 | else |
244 | AC_MSG_RESULT([no]) | 226 | AC_MSG_RESULT([no]) |
245 | fi, | 227 | fi, |
246 | AC_MSG_RESULT([no]) | 228 | AC_MSG_RESULT([no]) |
247 | ) | 229 | ) |
248 | AC_SUBST(GNOME) | ||
249 | CXXFLAGS="$CXXFLAGS $GNOME" | ||
250 | 230 | ||
251 | dnl Check for Xinerama support | 231 | dnl Check for Xinerama support |
252 | XINERAMA="" | 232 | |
253 | AC_MSG_CHECKING([whether to build support for the Xinerama extension]) | 233 | AC_MSG_CHECKING([whether to build support for the Xinerama extension]) |
254 | AC_ARG_ENABLE(xinerama, | 234 | AC_ARG_ENABLE(xinerama, |
255 | [ --enable-xinerama enable xinerama extension [default=no]], , [enable_xinerama=no]) | 235 | [ --enable-xinerama enable xinerama extension [default=no]], , [enable_xinerama=no]) |
@@ -284,7 +264,9 @@ AC_MSG_RESULT([]) | |||
284 | 264 | ||
285 | dnl Output files | 265 | dnl Output files |
286 | AM_CONFIG_HEADER(config.h) | 266 | AM_CONFIG_HEADER(config.h) |
267 | |||
287 | AC_OUTPUT(Makefile | 268 | AC_OUTPUT(Makefile |
269 | version.h | ||
288 | src/Makefile | 270 | src/Makefile |
289 | util/Makefile | 271 | util/Makefile |
290 | util/fbrun/Makefile | 272 | util/fbrun/Makefile |
@@ -306,4 +288,4 @@ nls/pt_PT/Makefile | |||
306 | nls/bg_BG/Makefile | 288 | nls/bg_BG/Makefile |
307 | nls/ja_JP/Makefile | 289 | nls/ja_JP/Makefile |
308 | nls/lv_LV/Makefile | 290 | nls/lv_LV/Makefile |
309 | version.h) | 291 | ) |