diff options
Diffstat (limited to 'configure.in')
-rw-r--r-- | configure.in | 69 |
1 files changed, 49 insertions, 20 deletions
diff --git a/configure.in b/configure.in index ae628f5..3215fa3 100644 --- a/configure.in +++ b/configure.in | |||
@@ -100,21 +100,23 @@ AC_ARG_ENABLE( | |||
100 | AC_DEFINE(SLIT, 1, " compile with slit") | 100 | AC_DEFINE(SLIT, 1, " compile with slit") |
101 | ) | 101 | ) |
102 | 102 | ||
103 | 103 | AC_MSG_CHECKING([whether to include the new WM Spec]) | |
104 | dnl Check for the new WM Spec | ||
105 | AC_MSG_CHECKING([whether to include the new WM Spec (DOES NOTHING)]) | ||
106 | AC_ARG_ENABLE( | 104 | AC_ARG_ENABLE( |
107 | newspec, | 105 | newwmspec, |
108 | [ --enable-newspec include code for the new WM Spec (DOES NOTHING) | 106 | [ --enable-newwmspec include code for the new WM Spec [default=yes]], |
109 | [default=no]], | ||
110 | if test x$enableval = "xyes"; then | 107 | if test x$enableval = "xyes"; then |
111 | AC_MSG_RESULT([yes]) | 108 | AC_MSG_RESULT([yes]) |
112 | AC_DEFINE(NEWWMSPEC, 1, "Extended Window Manager Hints") | 109 | NEWWMSPEC=true |
110 | AC_DEFINE(USE_NEWWMSPEC, 1, " use extened window manager hints") | ||
113 | else | 111 | else |
114 | AC_MSG_RESULT([no]) | 112 | AC_MSG_RESULT([no]) |
113 | NEWWMSPEC=false | ||
115 | fi, | 114 | fi, |
116 | AC_MSG_RESULT([no]) | 115 | AC_MSG_RESULT([yes]) |
116 | AC_DEFINE(USE_NEWWMSPEC, 1, " use extened window manager hints") | ||
117 | NEWWMSPEC=true | ||
117 | ) | 118 | ) |
119 | AM_CONDITIONAL(NEWWMSPEC, test x$NEWWMSPEC = xtrue) | ||
118 | 120 | ||
119 | 121 | ||
120 | dnl Check for Interlacing | 122 | dnl Check for Interlacing |
@@ -218,37 +220,64 @@ dnl Check GNOME | |||
218 | AC_MSG_CHECKING([whether to have GNOME support]) | 220 | AC_MSG_CHECKING([whether to have GNOME support]) |
219 | AC_ARG_ENABLE( | 221 | AC_ARG_ENABLE( |
220 | gnome, | 222 | gnome, |
221 | [ --enable-gnome GNOME support [default=no]], | 223 | [ --enable-gnome GNOME support [default=yes]], |
222 | if test x$enableval = "xyes"; then | 224 | if test x$enableval = "xyes"; then |
223 | AC_MSG_RESULT([yes]) | 225 | AC_MSG_RESULT([yes]) |
224 | AC_DEFINE(GNOME, 1, "Gnome 1 support") | 226 | AC_DEFINE(USE_GNOME, 1, "Gnome 1 support") |
227 | GNOME=true | ||
225 | else | 228 | else |
226 | AC_MSG_RESULT([no]) | 229 | AC_MSG_RESULT([no]) |
230 | GNOME=false | ||
227 | fi, | 231 | fi, |
228 | AC_MSG_RESULT([no]) | 232 | AC_MSG_RESULT([yes]) |
233 | AC_DEFINE(USE_GNOME, 1, "Gnome 1 support") | ||
234 | GNOME=true | ||
229 | ) | 235 | ) |
230 | 236 | AM_CONDITIONAL(GNOME, test x$GNOME = xtrue) | |
231 | 237 | ||
232 | AC_MSG_CHECKING([whether to have Xft support]) | 238 | AC_MSG_CHECKING([whether to have Xft support]) |
233 | AC_ARG_ENABLE( | 239 | AC_ARG_ENABLE( |
234 | xft, | 240 | xft, |
235 | [ --enable-xft Xft (antialias) support [default=no]], | 241 | [ --enable-xft Xft (antialias) support [default=yes]], |
236 | if test x$enableval = "xyes"; then | 242 | if test x$enableval = "xyes"; then |
237 | AC_MSG_RESULT([yes]) | ||
238 | AC_CHECK_LIB(Xft, XftFontOpen, | 243 | AC_CHECK_LIB(Xft, XftFontOpen, |
239 | LIBS="$LIBS -lXft" | 244 | LIBS="$LIBS -lXft" |
240 | XFT=true | 245 | XFT=true |
241 | AC_DEFINE(USE_XFT, 1, "antialias support"), | 246 | AC_DEFINE(USE_XFT, 1, "antialias support"), |
242 | AC_MSG_ERROR([Could not find XftFontOpen in -lXft.]) | 247 | AC_MSG_RESULT([no]) |
248 | XFT=false | ||
243 | ) | 249 | ) |
244 | else | 250 | else |
245 | AC_MSG_RESULT([no]) | 251 | AC_MSG_RESULT([no]) |
246 | XFT=false | 252 | XFT=false |
247 | fi, | 253 | fi, |
248 | AC_MSG_RESULT([no]) | 254 | AC_CHECK_LIB(Xft, XftFontOpen, |
249 | XFT=false | 255 | LIBS="$LIBS -lXft" |
256 | XFT=true | ||
257 | AC_DEFINE(USE_XFT, 1, "antialias support"), | ||
258 | AC_MSG_RESULT([no]) | ||
259 | XFT=false | ||
260 | ) | ||
261 | ) | ||
262 | AM_CONDITIONAL(XFT, test x$XFT = xtrue) | ||
263 | |||
264 | AC_MSG_CHECKING([whether to have Xmb (multibyte font, utf-8) support]) | ||
265 | AC_ARG_ENABLE( | ||
266 | xmb, | ||
267 | [ --enable-xmb Xmb (multibyte font, utf-8) support [default=yes]], | ||
268 | if test x$enableval = "xyes"; then | ||
269 | AC_MSG_RESULT([yes]) | ||
270 | AC_DEFINE(USE_XMB, 1, "multibyte support") | ||
271 | MULTIBYTE=true | ||
272 | else | ||
273 | AC_MSG_RESULT([no]) | ||
274 | MULTIBYTE=false | ||
275 | fi, | ||
276 | AC_MSG_RESULT([yes]) | ||
277 | AC_DEFINE(USE_XMB, 1, "multibyte support") | ||
278 | MULTIBYTE=true | ||
250 | ) | 279 | ) |
251 | AM_CONDITIONAL(XFT, test x$XFT = xtrue) | 280 | AM_CONDITIONAL(MULTIBYTE, test x$MULTIBYTE = xtrue) |
252 | 281 | ||
253 | dnl Check for Xinerama support | 282 | dnl Check for Xinerama support |
254 | 283 | ||
@@ -305,9 +334,9 @@ nls/pt_BR/Makefile | |||
305 | nls/ru_RU/Makefile | 334 | nls/ru_RU/Makefile |
306 | nls/sv_SE/Makefile | 335 | nls/sv_SE/Makefile |
307 | nls/tr_TR/Makefile | 336 | nls/tr_TR/Makefile |
308 | nls/it_IT/Makefile | ||
309 | nls/pt_PT/Makefile | 337 | nls/pt_PT/Makefile |
310 | nls/bg_BG/Makefile | 338 | nls/bg_BG/Makefile |
311 | nls/ja_JP/Makefile | 339 | nls/ja_JP/Makefile |
312 | nls/lv_LV/Makefile | 340 | nls/lv_LV/Makefile |
341 | nls/it_IT/Makefile | ||
313 | ) | 342 | ) |