aboutsummaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in157
1 files changed, 101 insertions, 56 deletions
diff --git a/configure.in b/configure.in
index 7b58aa0..966d7b5 100644
--- a/configure.in
+++ b/configure.in
@@ -1,7 +1,8 @@
1dnl configure.in for Fluxbox - created from configure.in Blackbox 0.61.1 1dnl configure.in for Fluxbox - created from configure.in Blackbox 0.61.1
2dnl Initialize autoconf and automake 2dnl Initialize autoconf and automake
3AC_INIT(src/main.cc) 3AC_INIT(src/main.cc)
4AM_INIT_AUTOMAKE(fluxbox,0.1.5,no-define) 4AC_PREREQ(2.52)
5AM_INIT_AUTOMAKE(fluxbox,0.9.0,no-define)
5 6
6dnl Determine default prefix 7dnl Determine default prefix
7test x$prefix = "xNONE" && prefix="$ac_default_prefix" 8test x$prefix = "xNONE" && prefix="$ac_default_prefix"
@@ -10,8 +11,7 @@ dnl Check for various flavors of UNIX(r)
10dnl AC_AIX 11dnl AC_AIX
11dnl AC_ISC_POSIX 12dnl AC_ISC_POSIX
12 13
13dnl TODO: do this 14AC_LANG_CPLUSPLUS
14dnl AC_LANG_CPLUSPLUS
15 15
16dnl Locate required external software 16dnl Locate required external software
17AC_PROG_CC 17AC_PROG_CC
@@ -84,74 +84,54 @@ else
84 AC_MSG_RESULT([no]) 84 AC_MSG_RESULT([no])
85fi 85fi
86AC_SUBST(SHAPE) 86AC_SUBST(SHAPE)
87 87CXXFLAGS="$CXXFLAGS $SHAPE"
88LIBS="$LIBS $Xext_lib" 88LIBS="$LIBS $Xext_lib"
89 89
90dnl Check for the Slit 90dnl Check for the Slit
91SLIT=""
92AC_MSG_CHECKING([whether to include the Slit]) 91AC_MSG_CHECKING([whether to include the Slit])
93AC_ARG_ENABLE( 92AC_ARG_ENABLE(
94 slit, [ --enable-slit include code for the Slit [default=yes]], 93 slit, [ --enable-slit include code for the Slit [default=yes]],
95 if test x$enableval = "xyes"; then 94 if test x$enableval = "xyes"; then
96 AC_MSG_RESULT([yes]) 95 AC_MSG_RESULT([yes])
97 SLIT="-DSLIT" 96 AC_DEFINE(SLIT, 1, " compile with slit")
98 else 97 else
99 AC_MSG_RESULT([no]) 98 AC_MSG_RESULT([no])
100 fi, 99 fi,
101 AC_MSG_RESULT([yes]) 100 AC_MSG_RESULT([yes])
102 SLIT="-DSLIT" 101 AC_DEFINE(SLIT, 1, " compile with slit")
103)
104AC_SUBST(SLIT)
105
106dnl Check for the new WM Spec
107NEWWMSPEC=""
108AC_MSG_CHECKING([whether to include the new WM Spec (DOES NOTHING)])
109AC_ARG_ENABLE(
110 newspec,
111[ --enable-newspec include code for the new WM Spec (DOES NOTHING)
112 [default=no]],
113 if test x$enableval = "xyes"; then
114 AC_MSG_RESULT([yes])
115 NEWWMSPEC="-DNEWWMSPEC"
116 else
117 AC_MSG_RESULT([no])
118 fi,
119 AC_MSG_RESULT([no])
120) 102)
121AC_SUBST(NEWWMSPEC)
122
123 103
124dnl Check for Interlacing 104AC_MSG_CHECKING([whether to include the new WM Spec])
125INTERLACE=""
126AC_MSG_CHECKING([whether to include interlacing image code])
127AC_ARG_ENABLE( 105AC_ARG_ENABLE(
128 interlace, [ --enable-interlace include code for image interlacing [default=yes]], 106 newwmspec,
107[ --enable-newwmspec include code for the new WM Spec [default=yes]],
129 if test x$enableval = "xyes"; then 108 if test x$enableval = "xyes"; then
130 AC_MSG_RESULT([yes]) 109 AC_MSG_RESULT([yes])
131 INTERLACE="-DINTERLACE" 110 NEWWMSPEC=true
111 AC_DEFINE(USE_NEWWMSPEC, 1, " use extened window manager hints")
132 else 112 else
133 AC_MSG_RESULT([no]) 113 AC_MSG_RESULT([no])
114 NEWWMSPEC=false
134 fi, 115 fi,
135 AC_MSG_RESULT([yes]) 116 AC_MSG_RESULT([yes])
136 INTERLACE="-DINTERLACE" 117 AC_DEFINE(USE_NEWWMSPEC, 1, " use extened window manager hints")
118 NEWWMSPEC=true
137) 119)
138AC_SUBST(INTERLACE) 120AM_CONDITIONAL(NEWWMSPEC, test x$NEWWMSPEC = xtrue)
139 121
140dnl Check for ordered 8bpp dithering 122dnl Check for ordered 8bpp dithering
141ORDEREDPSEUDO=""
142AC_MSG_CHECKING([whether to include Pseudocolor ordered dithering code]) 123AC_MSG_CHECKING([whether to include Pseudocolor ordered dithering code])
143AC_ARG_ENABLE(ordered-pseudo, 124AC_ARG_ENABLE(ordered-pseudo,
144[ --enable-ordered-pseudo include code for ordered pseudocolor (8bpp) 125[ --enable-ordered-pseudo include code for ordered pseudocolor (8bpp)
145 dithering [default=no]], 126 dithering [default=no]],
146 if test x$enableval = "xyes"; then 127 if test x$enableval = "xyes"; then
147 AC_MSG_RESULT([yes]) 128 AC_MSG_RESULT([yes])
148 ORDEREDPSEUDO="-DORDEREDPSEUDO" 129 AC_DEFINE(ORDEREDPSEUDO, 1, "ordered dithering code")
149 else 130 else
150 AC_MSG_RESULT([no]) 131 AC_MSG_RESULT([no])
151 fi, 132 fi,
152 AC_MSG_RESULT([no]) 133 AC_MSG_RESULT([no])
153) 134)
154AC_SUBST(ORDEREDPSEUDO)
155 135
156dnl Check whether to include debugging code 136dnl Check whether to include debugging code
157DEBUG="" 137DEBUG=""
@@ -160,29 +140,28 @@ AC_ARG_ENABLE(debug,
160 [ --enable-debug include verbose debugging code [default=no]], 140 [ --enable-debug include verbose debugging code [default=no]],
161 if test x$enableval = "xyes"; then 141 if test x$enableval = "xyes"; then
162 AC_MSG_RESULT([yes]) 142 AC_MSG_RESULT([yes])
163 DEBUG="-DDEBUG" 143 DEBUG="-DDEBUG -fno-inline"
164 else 144 else
165 AC_MSG_RESULT([no]) 145 AC_MSG_RESULT([no])
166 fi, 146 fi,
167 AC_MSG_RESULT([no]) 147 AC_MSG_RESULT([no])
168) 148)
169AC_SUBST(DEBUG) 149AC_SUBST(DEBUG)
150CXXFLAGS="$CXXFLAGS $DEBUG"
170 151
171dnl Check whether to include natural language support (i18n) 152dnl Check whether to include natural language support (i18n)
172NLS=""
173AC_MSG_CHECKING([whether to include NLS support]) 153AC_MSG_CHECKING([whether to include NLS support])
174AC_ARG_ENABLE(nls, 154AC_ARG_ENABLE(nls,
175 [ --enable-nls include natural language support [default=yes]], 155 [ --enable-nls include natural language support [default=yes]],
176 if test x$enableval = "xyes"; then 156 if test x$enableval = "xyes"; then
177 AC_MSG_RESULT([yes]) 157 AC_MSG_RESULT([yes])
178 NLS="-DNLS" 158 AC_DEFINE(NLS, 1, "Natural language support")
179 else 159 else
180 AC_MSG_RESULT([no]) 160 AC_MSG_RESULT([no])
181 fi, 161 fi,
182 AC_MSG_RESULT([yes]) 162 AC_MSG_RESULT([yes])
183 NLS="-DNLS" 163 AC_DEFINE(NLS, 1, "Natural language support")
184) 164)
185AC_SUBST(NLS)
186 165
187AC_CHECK_LIB(xpg4, setlocale, LIBS="$LIBS -lxpg4") 166AC_CHECK_LIB(xpg4, setlocale, LIBS="$LIBS -lxpg4")
188 167
@@ -193,59 +172,116 @@ fi
193 172
194 173
195dnl Check for new timed pixmap cache 174dnl Check for new timed pixmap cache
196TIMEDCACHE=""
197AC_MSG_CHECKING([whether to use the new timed pixmap cache]) 175AC_MSG_CHECKING([whether to use the new timed pixmap cache])
198AC_ARG_ENABLE( 176AC_ARG_ENABLE(
199 timed-cache, 177 timed-cache,
200[ --enable-timed-cache use new timed pixmap cache [default=yes]], 178[ --enable-timed-cache use new timed pixmap cache [default=yes]],
201 if test x$enableval = "xyes"; then 179 if test x$enableval = "xyes"; then
202 AC_MSG_RESULT([yes]) 180 AC_MSG_RESULT([yes])
203 TIMEDCACHE="-DTIMEDCACHE" 181 AC_DEFINE(TIMEDCACHE, 1, "timed cache")
204 else 182 else
205 AC_MSG_RESULT([no]) 183 AC_MSG_RESULT([no])
206 fi, 184 fi,
207 AC_MSG_RESULT([yes]) 185 AC_MSG_RESULT([yes])
208 TIMEDCACHE="-DTIMEDCACHE" 186 AC_DEFINE(TIMEDCACHE, 1, "timed cache")
209) 187)
210AC_SUBST(TIMEDCACHE)
211 188
212dnl Check KDE 189dnl Check KDE
213KDE=""
214AC_MSG_CHECKING([whether to have KDE slit support]) 190AC_MSG_CHECKING([whether to have KDE slit support])
215AC_ARG_ENABLE( 191AC_ARG_ENABLE(
216 kde, 192 kde,
217[ --enable-kde KDE slit support [default=no]], 193[ --enable-kde KDE slit support [default=no]],
218 if test x$enableval = "xyes"; then 194 if test x$enableval = "xyes"; then
219 AC_MSG_RESULT([yes]) 195 AC_MSG_RESULT([yes])
220 KDE="-DKDE" 196 AC_DEFINE(KDE, 1, "KDE slit support")
221 else 197 else
222 AC_MSG_RESULT([no]) 198 AC_MSG_RESULT([no])
223 fi, 199 fi,
224 AC_MSG_RESULT([no]) 200 AC_MSG_RESULT([no])
225) 201)
226AC_SUBST(KDE)
227 202
228dnl Check GNOME 203dnl Check GNOME
229GNOME="" 204
230AC_MSG_CHECKING([whether to have GNOME support]) 205AC_MSG_CHECKING([whether to have GNOME support])
231AC_ARG_ENABLE( 206AC_ARG_ENABLE(
232 gnome, 207 gnome,
233[ --enable-gnome GNOME support [default=no] (DEVELOPMENT)], 208[ --enable-gnome GNOME support [default=yes]],
234 if test x$enableval = "xyes"; then 209 if test x$enableval = "xyes"; then
235 AC_MSG_RESULT([yes]) 210 AC_MSG_RESULT([yes])
236 GNOME="-DGNOME" 211 AC_DEFINE(USE_GNOME, 1, "Gnome 1 support")
212 GNOME=true
237 else 213 else
238 AC_MSG_RESULT([no]) 214 AC_MSG_RESULT([no])
215 GNOME=false
239 fi, 216 fi,
240 AC_MSG_RESULT([no]) 217 AC_MSG_RESULT([yes])
218 AC_DEFINE(USE_GNOME, 1, "Gnome 1 support")
219 GNOME=true
220)
221AM_CONDITIONAL(GNOME, test x$GNOME = xtrue)
222
223AC_MSG_CHECKING([whether to have Xft support])
224AM_PATH_XFT(yes,
225 XFT=true,
226 XFT=false
227)
228
229if test "x$XFT" = "xtrue" ; then
230 AC_DEFINE(USE_XFT, 1, "antialias support")
231 AC_MSG_CHECKING([Xft UTF-8 support])
232 AC_TRY_LINK([
233 #include <X11/Xft/Xft.h>
234 ], [ XftDrawStringUtf8(0, 0, 0, 0, 0, 0, 0); return 0; ],
235 AC_DEFINE(HAVE_XFT_UTF8_STRING, 1, "Xft UTF8 support")
236 AC_MSG_RESULT(yes),
237 AC_MSG_RESULT(no)
238 )
239fi
240
241AM_CONDITIONAL(XFT, test x$XFT = xtrue)
242
243
244AC_MSG_CHECKING([whether to have Xmb (multibyte font, utf-8) support])
245AC_ARG_ENABLE(
246 xmb,
247[ --enable-xmb Xmb (multibyte font, utf-8) support [default=yes]],
248 if test x$enableval = "xyes"; then
249 AC_MSG_RESULT([yes])
250 AC_DEFINE(USE_XMB, 1, "multibyte support")
251 MULTIBYTE=true
252 else
253 AC_MSG_RESULT([no])
254 MULTIBYTE=false
255 fi,
256 AC_MSG_RESULT([yes])
257 AC_DEFINE(USE_XMB, 1, "multibyte support")
258 MULTIBYTE=true
241) 259)
242AC_SUBST(GNOME) 260AM_CONDITIONAL(MULTIBYTE, test x$MULTIBYTE = xtrue)
261
262dnl Check for Xinerama support
263
264AC_MSG_CHECKING([whether to build support for the Xinerama extension])
265AC_ARG_ENABLE(xinerama,
266[ --enable-xinerama enable xinerama extension [default=no]], , [enable_xinerama=no])
267
268if test "x$enable_xinerama" = "xyes"; then
269 AC_MSG_RESULT([yes])
270 AC_CHECK_LIB(Xinerama, XineramaQueryScreens,
271 XINERAMA="-DXINERAMA"; Xinerama_libs="-lXinerama", )
272else
273 AC_MSG_RESULT([no])
274fi
275AC_SUBST(XINERAMA)
276CXXFLAGS="$CXXFLAGS $XINERAMA"
277
278LIBS="$LIBS $Xinerama_libs"
243 279
244dnl Determine the return type of signal handlers 280dnl Determine the return type of signal handlers
245AC_TYPE_SIGNAL 281AC_TYPE_SIGNAL
246 282
247dnl Determine if maintainer portions of the Makefiles should be included. 283dnl Determine if maintainer portions of the Makefiles should be included.
248AM_MAINTAINER_MODE 284dnl AM_MAINTAINER_MODE
249 285
250dnl Print results 286dnl Print results
251AC_MSG_RESULT([]) 287AC_MSG_RESULT([])
@@ -259,9 +295,13 @@ AC_MSG_RESULT([])
259 295
260dnl Output files 296dnl Output files
261AM_CONFIG_HEADER(config.h) 297AM_CONFIG_HEADER(config.h)
298
262AC_OUTPUT(Makefile 299AC_OUTPUT(Makefile
300version.h
263src/Makefile 301src/Makefile
302src/FbTk/Makefile
264util/Makefile 303util/Makefile
304util/fbrun/Makefile
265data/Makefile 305data/Makefile
266data/styles/Makefile 306data/styles/Makefile
267doc/Makefile 307doc/Makefile
@@ -275,5 +315,10 @@ nls/pt_BR/Makefile
275nls/ru_RU/Makefile 315nls/ru_RU/Makefile
276nls/sv_SE/Makefile 316nls/sv_SE/Makefile
277nls/tr_TR/Makefile 317nls/tr_TR/Makefile
318nls/pt_PT/Makefile
319nls/bg_BG/Makefile
320nls/ja_JP/Makefile
321nls/lv_LV/Makefile
278nls/it_IT/Makefile 322nls/it_IT/Makefile
279version.h) 323nls/de_DE/Makefile
324)