diff options
Diffstat (limited to 'Makefile.am')
-rw-r--r-- | Makefile.am | 81 |
1 files changed, 73 insertions, 8 deletions
diff --git a/Makefile.am b/Makefile.am index 136824f..1b09b39 100644 --- a/Makefile.am +++ b/Makefile.am | |||
@@ -1,17 +1,82 @@ | |||
1 | # Makefile.am for Fluxbox - http://fluxbox.org | 1 | # Makefile.am for Fluxbox - http://fluxbox.org |
2 | 2 | ||
3 | # data dir after util so that utils are built for path searching | 3 | ACLOCAL_AMFLAGS = -I m4 |
4 | # when generating menu | 4 | AM_CPPFLAGS = \ |
5 | -include $(top_builddir)/config.h | ||
5 | 6 | ||
6 | SUBDIRS = doc nls src util data | 7 | # the defaults.hh is wrote to builddir |
7 | MAINTAINERCLEANFILES = aclocal.m4 config.h.in configure Makefile.in stamp-h.in | 8 | src_incdir = $(top_srcdir)/src -I$(top_builddir)/src |
8 | ACLOCAL_AMFLAGS = -I . | 9 | fbtk_incdir = $(top_srcdir)/src/FbTk |
9 | EXTRA_DIST = acinclude.m4 $(top_srcdir)/3rd/vim/* $(top_srcdir)/3rd/vim/syntax/* | 10 | nls_incdir = $(top_srcdir)/nls |
11 | |||
12 | EXTRA_DIST = \ | ||
13 | 3rd/vim/ \ | ||
14 | build-aux/config.rpath \ | ||
15 | nls/fluxbox-nls.hh \ | ||
16 | nls/nlsinfo | ||
17 | |||
18 | CLEANFILES = | ||
19 | bin_PROGRAMS = | ||
20 | |||
21 | MAINTAINERCLEANFILES = \ | ||
22 | aclocal.m4 \ | ||
23 | config.h.in \ | ||
24 | configure \ | ||
25 | Makefile.in \ | ||
26 | stamp-h.in | ||
27 | |||
28 | DEFAULT_MENU=@DEFAULT_MENU@ | ||
29 | DEFAULT_STYLE=@DEFAULT_STYLE@ | ||
30 | DEFAULT_KEYSFILE=@DEFAULT_KEYS@ | ||
31 | DEFAULT_APPSFILE=@DEFAULT_APPS@ | ||
32 | DEFAULT_OVERLAY=@DEFAULT_OVERLAY@ | ||
33 | DEFAULT_INITFILE=@DEFAULT_INIT@ | ||
34 | DEFAULT_WINDOWMENU=@DEFAULT_WINDOWMENU@ | ||
35 | PROGRAM_PREFIX=@program_prefix@ | ||
36 | PROGRAM_SUFFIX=@program_suffix@ | ||
37 | |||
38 | # Do not rely on configure.ac AC_CONFIG_FILES for install paths. The | ||
39 | # paths should be expanded at make time rather than configure. | ||
40 | edit_cmd = sed \ | ||
41 | -e 's|@bindir[@]|$(bindir)|g' \ | ||
42 | -e 's|@datadir[@]|$(datadir)|g' \ | ||
43 | -e 's|@exec_prefix[@]|$(exec_prefix)|g' \ | ||
44 | -e 's|@includedir[@]|$(includedir)|g' \ | ||
45 | -e 's|@localstatedir[@]|$(localstatedir)|g' \ | ||
46 | -e 's|@pkgbindir[@]|$(pkgbindir)|g' \ | ||
47 | -e 's|@pkgdatadir[@]|$(pkgdatadir)|g' \ | ||
48 | -e 's|@pkgprefix[@]|$(pkgprefix:NONE=)|g' \ | ||
49 | -e 's|@pkgsuffix[@]|$(pkgsuffix:NONE=)|g' \ | ||
50 | -e 's|@prefix[@]|$(prefix)|g' \ | ||
51 | -e 's|@sbindir[@]|$(sbindir)|g' \ | ||
52 | -e 's|@sysconfdir[@]|$(sysconfdir)|g' \ | ||
53 | -e 's|@usrbin_execdir[@]|$(usrbin_execdir)|g' \ | ||
54 | -e 's|@usrlib_execdir[@]|$(usrlib_execdir)|g' \ | ||
55 | -e 's|@usrsbin_execdir[@]|$(usrsbin_execdir)|g' \ | ||
56 | -e 's|@VERSION[@]|$(VERSION)|g' | ||
57 | |||
58 | PATHFILES = | ||
59 | CLEANFILES += $(PATHFILES) | ||
60 | EXTRA_DIST += $(PATHFILES:=.in) | ||
61 | |||
62 | $(PATHFILES): Makefile | ||
63 | @ rm -f $@ $@.tmp | ||
64 | $(AM_V_GEN) srcdir=''; \ | ||
65 | test -f ./$@.in || srcdir=$(srcdir)/; \ | ||
66 | $(edit_cmd) $${srcdir}$@.in >$@.tmp | ||
67 | @ mv $@.tmp $@ | ||
68 | |||
69 | include data/Makemodule.am | ||
70 | include doc/Makemodule.am | ||
71 | include nls/Makemodule.am | ||
72 | include src/FbTk/Makemodule.am | ||
73 | include src/Makemodule.am | ||
74 | include src/tests/Makemodule.am | ||
75 | include util/Makemodule.am | ||
76 | include util/fbrun/Makemodule.am | ||
10 | 77 | ||
11 | uninstall-hook: | 78 | uninstall-hook: |
12 | rmdir $(DESTDIR)$(pkgdatadir) | 79 | rmdir $(DESTDIR)$(pkgdatadir) |
13 | distclean-local: | ||
14 | rm -f *\~ | ||
15 | 80 | ||
16 | source-doc: | 81 | source-doc: |
17 | doxygen Doxyfile | 82 | doxygen Doxyfile |