aboutsummaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorfluxgen <fluxgen>2001-12-11 20:47:02 (GMT)
committerfluxgen <fluxgen>2001-12-11 20:47:02 (GMT)
commit18830ac9add80cbd3bf7369307d7e35a519dca9b (patch)
tree4759a5434a34ba317fe77bbf8b0ed9bb57bb6018 /src/Makefile.am
parent1523b48bff07dead084af3064ad11c79a9b25df0 (diff)
downloadfluxbox-18830ac9add80cbd3bf7369307d7e35a519dca9b.zip
fluxbox-18830ac9add80cbd3bf7369307d7e35a519dca9b.tar.bz2
Initial revision
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am55
1 files changed, 55 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
new file mode 100644
index 0000000..8e5f514
--- /dev/null
+++ b/src/Makefile.am
@@ -0,0 +1,55 @@
1# Makefile.am for fluxbox
2# Copyright (c) 2001 Henrik Kinnunen (fluxgen@linuxmail.org)
3#
4# src/Makefile.am for Blackbox 0.61.x - an X11 Window manager
5# Copyright (c) 1997 - 2000 Brad Hughes (bhughes@tcac.net)
6#
7# Permission is hereby granted, free of charge, to any person obtaining a
8# copy of this software and associated documentation files (the "Software"),
9# to deal in the Software without restriction, including without limitation
10# the rights to use, copy, modify, merge, publish, distribute, sublicense,
11# and/or sell copies of the Software, and to permit persons to whom the
12# Software is furnished to do so, subject to the following conditions:
13#
14# The above copyright notice and this permission notice shall be included in
15# all copies or substantial portions of the Software.
16#
17# THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
18# IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
19# FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL
20# THE AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
21# LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING
22# FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER
23# DEALINGS IN THE SOFTWARE.
24
25
26DEFAULT_MENU=$(pkgdatadir)/menu
27DEFAULT_STYLE=$(pkgdatadir)/styles/Clean
28DEFAULT_TITLEBAR=$(pkgdatadir)/titlebar
29DEFAULT_KEYSFILE=$(pkgdatadir)/keys
30DEFAULT_INITFILE=
31
32CPPFLAGS= -Wall @CPPFLAGS@ @SHAPE@ @SLIT@ @INTERLACE@ @ORDEREDPSEUDO@ \
33@DEBUG@ @NEWWMSPEC@ @NLS@ @TIMEDCACHE@ @KDE@ @GNOME@ \
34-DLOCALEPATH=\"$(pkgdatadir)/nls\" \
35-DDEFAULTMENU=\"$(DEFAULT_MENU)\" \
36-DDEFAULTSTYLE=\"$(DEFAULT_STYLE)\" \
37-DDEFAULTTITLEBAR=\"$(DEFAULT_TITLEBAR)\"\
38-DDEFAULTKEYSFILE=\"$(DEFAULT_KEYSFILE)\"\
39-DDEFAULT_INITFILE=\"$(pkgdatadir)/init\"
40
41bin_PROGRAMS= fluxbox
42
43fluxbox_SOURCES= BaseDisplay.cc BaseDisplay.hh Basemenu.cc Basemenu.hh \
44 Clientmenu.cc Clientmenu.hh Configmenu.cc Configmenu.hh \
45 Icon.cc Icon.hh Image.cc Image.hh LinkedList.cc LinkedList.hh \
46 Netizen.cc Netizen.hh Rootmenu.cc Rootmenu.hh Screen.cc Screen.hh\
47 Slit.cc Slit.hh Timer.cc Timer.hh Toolbar.cc Toolbar.hh \
48 Window.cc Window.hh Windowmenu.cc Windowmenu.hh \
49 Workspace.cc Workspace.hh Workspacemenu.cc Workspacemenu.hh \
50 fluxbox.cc fluxbox.hh bsd-snprintf.c bsd-snprintf.h \
51 i18n.cc i18n.hh main.cc Tab.hh Tab.cc Keys.cc Keys.hh\
52 IconBar.cc IconBar.hh Theme.hh Theme.cc misc.hh misc.cc \
53 Rotated.hh
54MAINTAINERCLEANFILES= Makefile.in
55