diff options
author | fluxgen <fluxgen> | 2001-12-11 20:47:02 (GMT) |
---|---|---|
committer | fluxgen <fluxgen> | 2001-12-11 20:47:02 (GMT) |
commit | 18830ac9add80cbd3bf7369307d7e35a519dca9b (patch) | |
tree | 4759a5434a34ba317fe77bbf8b0ed9bb57bb6018 /configure.in | |
parent | 1523b48bff07dead084af3064ad11c79a9b25df0 (diff) | |
download | fluxbox-18830ac9add80cbd3bf7369307d7e35a519dca9b.zip fluxbox-18830ac9add80cbd3bf7369307d7e35a519dca9b.tar.bz2 |
Initial revision
Diffstat (limited to 'configure.in')
-rw-r--r-- | configure.in | 279 |
1 files changed, 279 insertions, 0 deletions
diff --git a/configure.in b/configure.in new file mode 100644 index 0000000..7b58aa0 --- /dev/null +++ b/configure.in | |||
@@ -0,0 +1,279 @@ | |||
1 | dnl configure.in for Fluxbox - created from configure.in Blackbox 0.61.1 | ||
2 | dnl Initialize autoconf and automake | ||
3 | AC_INIT(src/main.cc) | ||
4 | AM_INIT_AUTOMAKE(fluxbox,0.1.5,no-define) | ||
5 | |||
6 | dnl Determine default prefix | ||
7 | test x$prefix = "xNONE" && prefix="$ac_default_prefix" | ||
8 | |||
9 | dnl Check for various flavors of UNIX(r) | ||
10 | dnl AC_AIX | ||
11 | dnl AC_ISC_POSIX | ||
12 | |||
13 | dnl TODO: do this | ||
14 | dnl AC_LANG_CPLUSPLUS | ||
15 | |||
16 | dnl Locate required external software | ||
17 | AC_PROG_CC | ||
18 | AC_PROG_CXX | ||
19 | AC_PROG_INSTALL | ||
20 | AM_PROG_LIBTOOL | ||
21 | |||
22 | AC_CHECK_PROGS(regex_cmd, sed) | ||
23 | if test x$regex_cmd = "x"; then | ||
24 | AC_MSG_ERROR([error. sed is required to build the data files.]) | ||
25 | fi | ||
26 | |||
27 | dnl Check for system header files | ||
28 | AC_HEADER_STDC | ||
29 | AC_CHECK_HEADERS(errno.h ctype.h dirent.h fcntl.h libgen.h locale.h nl_types.h process.h signal.h stdarg.h stdio.h time.h unistd.h sys/param.h sys/select.h sys/signal.h sys/stat.h sys/time.h sys/types.h sys/wait.h) | ||
30 | AC_HEADER_TIME | ||
31 | |||
32 | dnl Check for existance of basename(), setlocale() and strftime() | ||
33 | AC_CHECK_FUNCS(basename, , AC_CHECK_LIB(gen, basename, LIBS="$LIBS -lgen")) | ||
34 | AC_CHECK_FUNCS(getpid setlocale sigaction strftime strcasestr snprintf vsnprintf catopen catgets catclose) | ||
35 | AC_CHECK_LIB(nsl, t_open, LIBS="$LIBS -lnsl") | ||
36 | AC_CHECK_LIB(socket, socket, LIBS="$LIBS -lsocket") | ||
37 | |||
38 | dnl Check for X headers and libraries | ||
39 | AC_PATH_X | ||
40 | AC_PATH_XTRA | ||
41 | |||
42 | test x$no_x = "xyes" && AC_MSG_ERROR([Fluxbox requires the X Window System libraries and headers.]) | ||
43 | |||
44 | test x$x_includes = "x" && x_includes="/usr/include" | ||
45 | test x$x_libraries = "x" && x_libraries="/usr/lib" | ||
46 | |||
47 | CFLAGS="$CFLAGS $X_CFLAGS" | ||
48 | CXXFLAGS="$CXXFLAGS $X_CFLAGS" | ||
49 | LIBS="$LIBS $X_LIBS" | ||
50 | LDFLAGS="$LDFLAGS $LIBS $X_PRE_LIBS" | ||
51 | |||
52 | dnl Check for required functions in -lX11 | ||
53 | AC_CHECK_LIB(X11, XOpenDisplay, | ||
54 | LIBS="$LIBS -lX11", | ||
55 | AC_MSG_ERROR([Could not find XOpenDisplay in -lX11.]) | ||
56 | ) | ||
57 | |||
58 | LIBS="$LIBS $X_EXTRA_LIBS" | ||
59 | |||
60 | Xext_lib="" | ||
61 | |||
62 | dnl Check for XShape extension support and proper library files. | ||
63 | SHAPE="" | ||
64 | AC_MSG_CHECKING([whether to build support for the XShape extension]) | ||
65 | AC_ARG_ENABLE( | ||
66 | shape, [ --enable-shape enable support of the XShape extension [default=yes]]) | ||
67 | |||
68 | : ${enableval="yes"} | ||
69 | if test x$enableval = "xyes"; then | ||
70 | AC_MSG_RESULT([yes]) | ||
71 | AC_CHECK_LIB(Xext, XShapeCombineShape, | ||
72 | AC_MSG_CHECKING([for X11/extensions/shape.h]) | ||
73 | AC_TRY_LINK( | ||
74 | #include <X11/Xlib.h> | ||
75 | #include <X11/Xutil.h> | ||
76 | #include <X11/extensions/shape.h> | ||
77 | , long foo = ShapeSet, | ||
78 | AC_MSG_RESULT([yes]) | ||
79 | SHAPE="-DSHAPE"; Xext_lib="-lXext", | ||
80 | AC_MSG_RESULT([no]) | ||
81 | ) | ||
82 | ) | ||
83 | else | ||
84 | AC_MSG_RESULT([no]) | ||
85 | fi | ||
86 | AC_SUBST(SHAPE) | ||
87 | |||
88 | LIBS="$LIBS $Xext_lib" | ||
89 | |||
90 | dnl Check for the Slit | ||
91 | SLIT="" | ||
92 | AC_MSG_CHECKING([whether to include the Slit]) | ||
93 | AC_ARG_ENABLE( | ||
94 | slit, [ --enable-slit include code for the Slit [default=yes]], | ||
95 | if test x$enableval = "xyes"; then | ||
96 | AC_MSG_RESULT([yes]) | ||
97 | SLIT="-DSLIT" | ||
98 | else | ||
99 | AC_MSG_RESULT([no]) | ||
100 | fi, | ||
101 | AC_MSG_RESULT([yes]) | ||
102 | SLIT="-DSLIT" | ||
103 | ) | ||
104 | AC_SUBST(SLIT) | ||
105 | |||
106 | dnl Check for the new WM Spec | ||
107 | NEWWMSPEC="" | ||
108 | AC_MSG_CHECKING([whether to include the new WM Spec (DOES NOTHING)]) | ||
109 | AC_ARG_ENABLE( | ||
110 | newspec, | ||
111 | [ --enable-newspec include code for the new WM Spec (DOES NOTHING) | ||
112 | [default=no]], | ||
113 | if test x$enableval = "xyes"; then | ||
114 | AC_MSG_RESULT([yes]) | ||
115 | NEWWMSPEC="-DNEWWMSPEC" | ||
116 | else | ||
117 | AC_MSG_RESULT([no]) | ||
118 | fi, | ||
119 | AC_MSG_RESULT([no]) | ||
120 | ) | ||
121 | AC_SUBST(NEWWMSPEC) | ||
122 | |||
123 | |||
124 | dnl Check for Interlacing | ||
125 | INTERLACE="" | ||
126 | AC_MSG_CHECKING([whether to include interlacing image code]) | ||
127 | AC_ARG_ENABLE( | ||
128 | interlace, [ --enable-interlace include code for image interlacing [default=yes]], | ||
129 | if test x$enableval = "xyes"; then | ||
130 | AC_MSG_RESULT([yes]) | ||
131 | INTERLACE="-DINTERLACE" | ||
132 | else | ||
133 | AC_MSG_RESULT([no]) | ||
134 | fi, | ||
135 | AC_MSG_RESULT([yes]) | ||
136 | INTERLACE="-DINTERLACE" | ||
137 | ) | ||
138 | AC_SUBST(INTERLACE) | ||
139 | |||
140 | dnl Check for ordered 8bpp dithering | ||
141 | ORDEREDPSEUDO="" | ||
142 | AC_MSG_CHECKING([whether to include Pseudocolor ordered dithering code]) | ||
143 | AC_ARG_ENABLE(ordered-pseudo, | ||
144 | [ --enable-ordered-pseudo include code for ordered pseudocolor (8bpp) | ||
145 | dithering [default=no]], | ||
146 | if test x$enableval = "xyes"; then | ||
147 | AC_MSG_RESULT([yes]) | ||
148 | ORDEREDPSEUDO="-DORDEREDPSEUDO" | ||
149 | else | ||
150 | AC_MSG_RESULT([no]) | ||
151 | fi, | ||
152 | AC_MSG_RESULT([no]) | ||
153 | ) | ||
154 | AC_SUBST(ORDEREDPSEUDO) | ||
155 | |||
156 | dnl Check whether to include debugging code | ||
157 | DEBUG="" | ||
158 | AC_MSG_CHECKING([whether to include verbose debugging code]) | ||
159 | AC_ARG_ENABLE(debug, | ||
160 | [ --enable-debug include verbose debugging code [default=no]], | ||
161 | if test x$enableval = "xyes"; then | ||
162 | AC_MSG_RESULT([yes]) | ||
163 | DEBUG="-DDEBUG" | ||
164 | else | ||
165 | AC_MSG_RESULT([no]) | ||
166 | fi, | ||
167 | AC_MSG_RESULT([no]) | ||
168 | ) | ||
169 | AC_SUBST(DEBUG) | ||
170 | |||
171 | dnl Check whether to include natural language support (i18n) | ||
172 | NLS="" | ||
173 | AC_MSG_CHECKING([whether to include NLS support]) | ||
174 | AC_ARG_ENABLE(nls, | ||
175 | [ --enable-nls include natural language support [default=yes]], | ||
176 | if test x$enableval = "xyes"; then | ||
177 | AC_MSG_RESULT([yes]) | ||
178 | NLS="-DNLS" | ||
179 | else | ||
180 | AC_MSG_RESULT([no]) | ||
181 | fi, | ||
182 | AC_MSG_RESULT([yes]) | ||
183 | NLS="-DNLS" | ||
184 | ) | ||
185 | AC_SUBST(NLS) | ||
186 | |||
187 | AC_CHECK_LIB(xpg4, setlocale, LIBS="$LIBS -lxpg4") | ||
188 | |||
189 | AC_CHECK_PROGS(gencat_cmd, gencat) | ||
190 | if test x$gencat_cmd = "x"; then | ||
191 | NLS="" | ||
192 | fi | ||
193 | |||
194 | |||
195 | dnl Check for new timed pixmap cache | ||
196 | TIMEDCACHE="" | ||
197 | AC_MSG_CHECKING([whether to use the new timed pixmap cache]) | ||
198 | AC_ARG_ENABLE( | ||
199 | timed-cache, | ||
200 | [ --enable-timed-cache use new timed pixmap cache [default=yes]], | ||
201 | if test x$enableval = "xyes"; then | ||
202 | AC_MSG_RESULT([yes]) | ||
203 | TIMEDCACHE="-DTIMEDCACHE" | ||
204 | else | ||
205 | AC_MSG_RESULT([no]) | ||
206 | fi, | ||
207 | AC_MSG_RESULT([yes]) | ||
208 | TIMEDCACHE="-DTIMEDCACHE" | ||
209 | ) | ||
210 | AC_SUBST(TIMEDCACHE) | ||
211 | |||
212 | dnl Check KDE | ||
213 | KDE="" | ||
214 | AC_MSG_CHECKING([whether to have KDE slit support]) | ||
215 | AC_ARG_ENABLE( | ||
216 | kde, | ||
217 | [ --enable-kde KDE slit support [default=no]], | ||
218 | if test x$enableval = "xyes"; then | ||
219 | AC_MSG_RESULT([yes]) | ||
220 | KDE="-DKDE" | ||
221 | else | ||
222 | AC_MSG_RESULT([no]) | ||
223 | fi, | ||
224 | AC_MSG_RESULT([no]) | ||
225 | ) | ||
226 | AC_SUBST(KDE) | ||
227 | |||
228 | dnl Check GNOME | ||
229 | GNOME="" | ||
230 | AC_MSG_CHECKING([whether to have GNOME support]) | ||
231 | AC_ARG_ENABLE( | ||
232 | gnome, | ||
233 | [ --enable-gnome GNOME support [default=no] (DEVELOPMENT)], | ||
234 | if test x$enableval = "xyes"; then | ||
235 | AC_MSG_RESULT([yes]) | ||
236 | GNOME="-DGNOME" | ||
237 | else | ||
238 | AC_MSG_RESULT([no]) | ||
239 | fi, | ||
240 | AC_MSG_RESULT([no]) | ||
241 | ) | ||
242 | AC_SUBST(GNOME) | ||
243 | |||
244 | dnl Determine the return type of signal handlers | ||
245 | AC_TYPE_SIGNAL | ||
246 | |||
247 | dnl Determine if maintainer portions of the Makefiles should be included. | ||
248 | AM_MAINTAINER_MODE | ||
249 | |||
250 | dnl Print results | ||
251 | AC_MSG_RESULT([]) | ||
252 | AC_MSG_RESULT([ $PACKAGE version $VERSION configured successfully.]) | ||
253 | AC_MSG_RESULT([]) | ||
254 | AC_MSG_RESULT([Using '$prefix' for installation.]) | ||
255 | AC_MSG_RESULT([Using '$CXX' for C++ compiler.]) | ||
256 | AC_MSG_RESULT([Building with '$CXXFLAGS' for C++ compiler flags.]) | ||
257 | AC_MSG_RESULT([Building with '$LIBS' for linker flags.]) | ||
258 | AC_MSG_RESULT([]) | ||
259 | |||
260 | dnl Output files | ||
261 | AM_CONFIG_HEADER(config.h) | ||
262 | AC_OUTPUT(Makefile | ||
263 | src/Makefile | ||
264 | util/Makefile | ||
265 | data/Makefile | ||
266 | data/styles/Makefile | ||
267 | doc/Makefile | ||
268 | nls/Makefile | ||
269 | nls/C/Makefile | ||
270 | nls/da_DK/Makefile | ||
271 | nls/es_ES/Makefile | ||
272 | nls/et_EE/Makefile | ||
273 | nls/fr_FR/Makefile | ||
274 | nls/pt_BR/Makefile | ||
275 | nls/ru_RU/Makefile | ||
276 | nls/sv_SE/Makefile | ||
277 | nls/tr_TR/Makefile | ||
278 | nls/it_IT/Makefile | ||
279 | version.h) | ||