aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorSami Kerola <kerolasa@iki.fi>2012-12-30 18:26:11 (GMT)
committerMathias Gumz <akira at fluxbox dot org>2013-01-02 08:58:46 (GMT)
commit23602ef23d81c694911a98f9a0923a0cf21ce066 (patch)
treebd18faa7ec4fcba23b3a71cf5cac947bf20cb4e0 /configure.ac
parentf587cc9e7e8c40bce778ffc0811a3a6c29107b85 (diff)
downloadfluxbox-23602ef23d81c694911a98f9a0923a0cf21ce066.zip
fluxbox-23602ef23d81c694911a98f9a0923a0cf21ce066.tar.bz2
rename configure.in to configure.ac
It seems autoheader version 2.69 does not work with configure.in file, and AM_CONFIG_HEADER macro. aclocal: warning: autoconf input should be named 'configure.ac', not 'configure.in' configure.in:585: warning: macro 'AM_CONFIG_HEADER' not found in library Executing: autoheader autoheader: error: AC_CONFIG_HEADERS not found in configure.in
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac675
1 files changed, 675 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
new file mode 100644
index 0000000..afb7b94
--- /dev/null
+++ b/configure.ac
@@ -0,0 +1,675 @@
1dnl Initialize autoconf and automake
2AC_INIT(src/main.cc)
3AC_PREREQ(2.52)
4AM_INIT_AUTOMAKE(fluxbox,1.3.3,[no-define])
5
6dnl Determine default prefix
7AS_IF(test "x$prefix" = "xNONE",[prefix="$ac_default_prefix"])
8
9dnl Check for various flavors of UNIX(r)
10dnl AC_AIX
11dnl AC_ISC_POSIX
12
13AC_LANG_CPLUSPLUS
14
15dnl Locate required external software
16AC_PROG_CC
17AC_PROG_CXX
18AC_PROG_INSTALL
19AC_PROG_RANLIB
20
21AC_C_CONST
22AC_C_INLINE
23
24AC_TYPE_PID_T
25AC_TYPE_SIZE_T
26
27
28AC_CHECK_PROGS(regex_cmd, sed)
29AS_IF(test "x$regex_cmd" = "x",[AC_MSG_ERROR([error. sed is required to build the data files.])])
30
31dnl Check for system header files
32AC_HEADER_STDC
33AC_HEADER_STDBOOL
34AC_CHECK_HEADERS(errno.h ctype.h dirent.h fcntl.h libgen.h \
35 locale.h math.h nl_types.h process.h signal.h stdarg.h \
36 stdint.h stdio.h time.h unistd.h \
37 sys/param.h sys/select.h sys/signal.h sys/stat.h \
38 sys/time.h sys/types.h sys/wait.h \
39 langinfo.h iconv.h)
40
41
42
43AC_CHECK_HEADERS(sstream,,[
44 AC_CHECK_HEADERS(strstream,,[
45 AC_MSG_ERROR([Your libstdc++ doesn't have the sstream or strstream classes])]
46 )]
47)
48
49AC_CHECK_HEADERS(cassert cctype cerrno cmath cstdarg cstdint cstdio cstdlib cstring ctime)
50
51
52dnl Check for existance of basename(), setlocale() and strftime()
53AC_FUNC_CLOSEDIR_VOID
54AC_FUNC_ERROR_AT_LINE
55AC_FUNC_FORK
56AC_FUNC_MALLOC
57AC_FUNC_REALLOC
58AC_FUNC_SELECT_ARGTYPES
59AC_FUNC_STAT
60
61AC_CHECK_FUNCS(basename, , AC_CHECK_LIB(gen, basename, LIBS="-lgen $LIBS"))
62AC_CHECK_FUNCS(catclose catgets catopen getpid memset mkdir \
63 nl_langinfo putenv regcomp select setenv setlocale sigaction snprintf \
64 sqrt strcasecmp strcasestr strchr strstr strtol strtoul sync vsnprintf)
65
66
67dnl Windows requires the mingw-catgets library for the catgets function.
68AC_SEARCH_LIBS([catgets], [catgets], [], [])
69
70dnl The autoconf test for strftime is broken now (due to gcc 3.3 bug?):
71dnl Gcc 3.3 testprog = ``extern "C" char strftime;'', build with g++ test.cc
72dnl breaks with:
73dnl test.cc:1: error: nonnull argument with out-of-range operand number
74dnl (arg 1, operand 3)
75
76
77AC_MSG_CHECKING(for strftime)
78
79AC_COMPILE_IFELSE(
80[AC_LANG_PROGRAM([#include <time.h>],
81[[
82char * s;
83time_t t = time(NULL);
84size_t x = strftime(s, 5, "%a", localtime(&t));
85]]
86)],
87[
88 AC_DEFINE(HAVE_STRFTIME, 1, [Define to 1 if you have the 'strftime' function.])
89 AC_MSG_RESULT(yes)
90],
91[AC_MSG_RESULT(no)])
92
93
94AC_MSG_CHECKING(for clock_gettime)
95AC_COMPILE_IFELSE(
96 [AC_LANG_PROGRAM(
97 [#include <time.h>],
98 [[
99 clock_gettime(CLOCK_MONOTONIC, 0);
100 return 0;
101 ]]
102 )],
103 [
104 AC_DEFINE(HAVE_CLOCK_GETTIME, 1, [Define to 1 if you have the 'clock_gettime' function.])
105 AC_MSG_RESULT(yes)
106 # *bsd has clock_gettime() in libc
107 AC_CHECK_LIB(rt, clock_gettime, LIBS="-lrt $LIBS")
108 ],
109 [
110 AC_MSG_RESULT(no)
111 ]
112)
113
114AC_MSG_CHECKING(for mach_absolute_time)
115AC_COMPILE_IFELSE(
116 [AC_LANG_PROGRAM(
117 [#include <mach/mach_time.h>],
118 [[
119 mach_absolute_time();
120 return 0;
121 ]]
122 )],
123 [
124 AC_DEFINE(HAVE_MACH_ABSOLUTE_TIME, 1, [Define to 1 if you have the 'mach_absolute_time' function.])
125 AC_MSG_RESULT(yes)
126 #AC_CHECK_LIB(, clock_gettime, LIBS="-lrt $LIBS")
127 ],
128 [
129 AC_MSG_RESULT(no)
130 ]
131)
132
133
134
135
136AC_STRUCT_TM
137
138dnl ---------------
139dnl CHECK FOR ICONV
140dnl ---------------
141dnl Find iconv. It may be in libiconv and may be iconv() or libiconv()
142if test "x$ac_cv_header_iconv_h" = "xyes"; then
143 ac_found_iconv=no
144 AC_COMPILE_IFELSE(
145 [AC_LANG_PROGRAM(
146 [[#include <stdlib.h>
147 #include <iconv.h>]],
148 [[
149 iconv_open(NULL, NULL);
150 return 0;
151 ]]
152 )],
153 [
154 ac_found_iconv=yes
155 ],
156 [ ])
157
158 AC_COMPILE_IFELSE(
159 [AC_LANG_PROGRAM(
160 [[#include <stdlib.h>
161 #include <iconv.h>]],
162 [[
163 libiconv_open(NULL, NULL);
164 return 0;
165 ]]
166 )],
167 [
168 ac_found_iconv=yes
169 ],
170 [ ])
171
172 if test "x$ac_found_iconv" = xyes; then
173 AC_DEFINE(HAVE_ICONV, 1, [Define if you have the iconv() function.])
174 AC_CHECK_LIB(iconv, iconv_open, LIBS="-liconv $LIBS")
175 AC_CHECK_LIB(iconv, libiconv_open, LIBS="-liconv $LIBS")
176
177dnl Check if iconv uses const in prototype declaration
178 AC_CACHE_CHECK(for iconv declaration,
179 ac_cv_iconv_const,
180 [AC_COMPILE_IFELSE(
181 [AC_LANG_PROGRAM(
182 [[#include <stdlib.h>
183 #include <iconv.h>]],
184 [[
185 char **msg, **new_msg;
186 size_t result, inleft, outleft;
187 result = iconv((iconv_t)(-1), msg, &inleft, new_msg, &outleft);
188 return 0;
189 ]]
190 )],
191 [ac_cv_iconv_const=no],
192 [ac_cv_iconv_const=yes])
193 ])
194 if test "x$ac_cv_iconv_const" = xyes; then
195 AC_DEFINE(HAVE_CONST_ICONV, 1, [Define if you have the iconv() function.])
196 fi
197 fi
198fi
199
200AC_CHECK_LIB(nsl, t_open, LIBS="-lnsl $LIBS")
201AC_CHECK_LIB(socket, socket, LIBS="-lsocket $LIBS")
202
203dnl Check for X headers and libraries
204AC_PATH_X
205AC_PATH_XTRA
206
207test x$no_x = "xyes" && AC_MSG_ERROR([Fluxbox requires the X Window System libraries and headers.])
208
209AS_IF(test "x$x_includes" = "x",[x_includes="/usr/include"])
210AS_IF(test "x$x_libraries" = "x",[x_libraries="/usr/lib"])
211
212CFLAGS="$CFLAGS $X_CFLAGS"
213CXXFLAGS="$CXXFLAGS $X_CFLAGS"
214LIBS="$X_LIBS $LIBS"
215LDFLAGS="$LDFLAGS $LIBS $X_PRE_LIBS"
216
217
218dnl Check for required functions in -lX11
219AC_CHECK_LIB(X11, XOpenDisplay, LIBS="-lX11 $LIBS", AC_MSG_ERROR([Could not find XOpenDisplay in -lX11.]))
220LIBS="$X_EXTRA_LIBS $LIBS"
221
222AC_CHECK_LIB(xpg4, setlocale, LIBS="-lxpg4 $LIBS")
223AC_CHECK_PROGS(gencat_cmd, gencat)
224AS_IF(test "x$gencat_cmd" = "x",[NLS=""],[])
225
226Xext_lib=""
227
228
229
230dnl Check for Remember options
231AC_MSG_CHECKING([whether to include remember functionality])
232AC_ARG_ENABLE(remember,
233 AS_HELP_STRING([--enable-remember],[include Remembering attributes (default=yes)]),,[enable_remember=yes])
234AC_MSG_RESULT([$enable_remember])
235AS_IF(test "x$enable_remember" = "xyes",[AC_DEFINE(REMEMBER, 1, " compile with remember")],[])
236AM_CONDITIONAL(REMEMBER_SRC, test "x$enable_remember" = "xyes")
237
238
239AC_MSG_CHECKING([whether to have (POSIX) regular expression support])
240AC_ARG_ENABLE(regexp,
241 AS_HELP_STRING([--enable-regexp],[regular expression support (default=yes)]),,[enable_regexp=yes])
242AS_IF(test "x$enable_regexp" = "xyes",[
243 AC_EGREP_HEADER([regex_t],regex.h,
244 AC_DEFINE(USE_REGEXP, 1, "Regular Expression support")
245 AC_MSG_RESULT([yes])
246 REGEXP_SRC=true,
247 AC_MSG_RESULT([no])
248 REGEXP_SRC=false
249 )],[])
250AM_CONDITIONAL(REGEXP_SRC, test x$REGEXP_SRC = xtrue)
251
252
253
254
255dnl Check for the Slit
256AC_MSG_CHECKING([whether to include the Slit])
257AC_ARG_ENABLE(slit,
258 AS_HELP_STRING([--enable-slit],[include code for the Slit (default=yes)]),,[enable_slit=yes])
259AC_MSG_RESULT([$enable_slit])
260AS_IF(test "x$enable_slit" = "xyes",[AC_DEFINE(USE_SLIT, 1, " compile with slit")],[])
261AM_CONDITIONAL(SLIT_SRC, test "x$enable_slit" = "xyes")
262
263
264dnl Check for Toolbar options
265AC_MSG_CHECKING([whether to include Toolbar])
266AC_ARG_ENABLE(toolbar,
267 AS_HELP_STRING([--enable-toolbar],[include Toolbar (default=yes)]),,[enable_toolbar=yes])
268AC_MSG_RESULT([$enable_toolbar])
269AS_IF(test "x$enable_toolbar" = "xyes",[AC_DEFINE(USE_TOOLBAR, 1, " compile with toolbar")],[])
270AM_CONDITIONAL(TOOLBAR_SRC, test "x$enable_toolbar" = "xyes")
271
272
273
274AC_MSG_CHECKING([whether to support Extended Window Manager Hints])
275AC_ARG_ENABLE(ewmh,
276 AS_HELP_STRING([--enable-ewmh],[enable support for Extended Window Manager Hints (default=yes)]),,[enable_ewmh=yes])
277AC_MSG_RESULT([$enable_ewmh])
278AS_IF(test "x$enable_ewmh" = "xyes",[AC_DEFINE(USE_EWMH, 1, "use extened window manager hints")],[])
279AM_CONDITIONAL(EWMH, test "x$enable_ewmh" = "xyes")
280
281
282
283dnl Check whether to include debugging code
284DEBUG=""
285AC_MSG_CHECKING([whether to include verbose debugging code])
286AC_ARG_ENABLE(debug,
287 AS_HELP_STRING([--enable-debug],[include verbose debugging code (default=no)]),,[enable_debug=no])
288AC_MSG_RESULT([$enable_debug])
289AS_IF(test "x$enable_debug" = "xyes",[ DEBUG="-DDEBUG -Wall" ],[])
290AC_SUBST(DEBUG)
291CXXFLAGS="$CXXFLAGS $DEBUG"
292
293
294
295dnl Check whether to build test programs
296AC_MSG_CHECKING([whether to build test programs])
297AC_ARG_ENABLE(test,
298 AS_HELP_STRING([--enable-test],[build programs used in testing fluxbox (default=no)]),,[enable_test=no])
299AC_MSG_RESULT([$enable_test])
300AM_CONDITIONAL(TEST, test "x$enable_test" = "xyes")
301
302
303
304dnl Check whether to include native language support (i18n)
305AC_MSG_CHECKING([whether to include NLS support])
306AC_ARG_ENABLE(nls,
307 AS_HELP_STRING([--enable-nls],[include native language support (default=no)]),,[enable_nls=yes])
308AC_MSG_RESULT([$enable_nls])
309AS_IF(test "x$enable_nls" = "xyes",[
310 AC_DEFINE(NLS, 1, "Native language support")
311 NLS="-DNLS"],[])
312AC_SUBST(NLS)
313
314
315
316
317dnl Check for new timed pixmap cache
318AC_MSG_CHECKING([whether to use a timed pixmap cache])
319AC_ARG_ENABLE(timedcache,
320 AS_HELP_STRING([--enable-timedcache],[use new timed pixmap cache (default=yes)]),,[enable_timedcache=yes])
321AC_MSG_RESULT([$enable_timedcache])
322AS_IF(test "x$enable_timedcached" = "xyes",[
323 AC_DEFINE(TIMEDCACHE, 1, "timed cache")],[])
324
325
326
327AC_MSG_CHECKING([whether to have Xft support])
328AM_PATH_XFT(yes, XFT=true, XFT=false)
329
330AS_IF(test "x$XFT" = "xtrue",[
331 AC_TRY_LINK([
332 #include <X11/Xft/Xft.h>
333 ], [ XftFontClose(0, 0); return 1; ],
334 [
335
336 AC_DEFINE(USE_XFT, 1, "antialias support")
337 AC_MSG_CHECKING([Xft UTF-8 support])
338 AC_TRY_LINK([
339 #include <X11/Xft/Xft.h>
340 ], [ XftDrawStringUtf8(0, 0, 0, 0, 0, 0, 0); return 0; ],
341 AC_DEFINE(HAVE_XFT_UTF8_STRING, 1, "Xft UTF8 support")
342 FEATURES="$FEATURES XFT"
343 AC_MSG_RESULT(yes),
344 AC_MSG_RESULT(no)
345 )
346 ],
347 [ AC_MSG_RESULT([Could not link with Xft. Install Xft if you want support for it.])
348 XFT=false
349 ])])
350
351AM_CONDITIONAL(XFT, test "x$XFT" = "xtrue")
352
353
354AC_MSG_CHECKING([whether to have XRENDER (transparent) support])
355AC_ARG_ENABLE(xrender,
356 AS_HELP_STRING([--enable-xrender],[XRENDER (transparent) support (default=yes)]),,[enable_xrender=yes])
357AC_MSG_RESULT([$enable_xrender])
358AS_IF(test "x$enable_xrender" = "xyes",[
359 AC_CHECK_LIB(Xrender, XRenderCreatePicture,
360 AC_DEFINE(HAVE_XRENDER, 1, "Xrender support")
361 LIBS="-lXrender $LIBS")
362 ],[])
363
364
365XPM=false
366AC_MSG_CHECKING([whether to have XPM (pixmap themes) support])
367AC_ARG_ENABLE(xpm,
368 AS_HELP_STRING([--enable-xpm],[XPM (pixmap themes) support (default=yes)]),[],[enable_xpm=yes])
369AC_MSG_RESULT([$enable_xpm])
370AS_IF(test "x$enable_xpm" = "xyes",[
371 AC_CHECK_LIB(Xpm, XpmReadFileToPixmap,
372 AC_DEFINE(HAVE_XPM, 1, "Xpm support")
373 XPM=true
374 LIBS="-lXpm $LIBS")
375 ],[])
376
377AM_CONDITIONAL(XPM, test "x$XPM" = "xtrue")
378
379dnl Check whether to use imlib2
380IMLIB2=false
381AC_MSG_CHECKING([whether to have IMLIB2 (pixmap themes) support])
382AC_ARG_ENABLE(imlib2,
383 AS_HELP_STRING([--enable-imlib2], [IMLIB2 (pixmap themes) support (default=yes)]), , [enable_imlib2=yes])
384AC_MSG_RESULT([$enable_imlib2])
385AS_IF(test x$enable_imlib2 = "xyes",[
386 AC_PATH_GENERIC(imlib2, 1.0.0,[
387 IMLIB2=true
388 AC_DEFINE(HAVE_IMLIB2, [], [Imlib2 support])
389 LIBS="$IMLIB2_LIBS $LIBS"
390 CXXFLAGS="$CXXFLAGS $IMLIB2_CFLAGS"
391 FEATURES="$FEATURES IMLIB2"
392 ], []
393 )],[])
394
395AM_CONDITIONAL(IMLIB2, test "x$IMLIB2" = "xtrue")
396
397
398
399AC_MSG_CHECKING([whether to have XMB (multibyte font, utf-8) support])
400AC_ARG_ENABLE(xmb, AS_HELP_STRING([--enable-xmb],[XMB (multibyte font, utf-8) support (default=yes)]),,[enable_xmb=yes])
401AC_MSG_RESULT([$enable_xmb])
402AS_IF([test "x$enable_xmb" = "xyes"],[ AC_DEFINE(USE_XMB, 1, "multibyte support")], [])
403AM_CONDITIONAL(MULTIBYTE, test "x$enable_xmb" = "xyes")
404
405
406dnl Check for Xinerama support and proper library files.
407AC_MSG_CHECKING([whether to build support for the XINERAMA extension])
408AC_ARG_ENABLE(xinerama,
409 AS_HELP_STRING([--enable-xinerama], [XINERAMA extension support (default=yes)]), ,[enable_xinerama=yes])
410
411AS_IF(test "x$enable_xinerama" = "xyes",[
412 AC_CHECK_LIB(Xinerama, XineramaQueryScreens,
413 AC_MSG_CHECKING([for X11/extensions/Xinerama.h])
414 AC_TRY_COMPILE(
415#include <X11/Xlib.h>
416#include <X11/Xutil.h>
417#include <X11/extensions/Xinerama.h>
418 , XineramaQueryScreens(0, 0),
419 AC_MSG_RESULT([yes])
420 AC_DEFINE(XINERAMA, [1], [Define to 1 if you have XINERAMA])
421 LIBS="-lXinerama $LIBS"
422 FEATURES="$FEATURES XINERAMA",
423 AC_MSG_RESULT([no])))],[
424 AC_MSG_RESULT([no])
425 CONFIGOPTS="$CONFIGOPTS --disable-xinerama"])
426
427
428dnl Check for XShape extension support and proper library files.
429AC_MSG_CHECKING([whether to build support for the XSHAPE extension])
430AC_ARG_ENABLE(shape,
431 AS_HELP_STRING([--enable-shape], [XSHAPE extension support (default=yes)]), , [enable_shape=yes])
432AS_IF(test "x$enable_shape" = "xyes",[
433 AC_CHECK_LIB(Xext, XShapeCombineShape,
434 AC_MSG_CHECKING([for X11/extensions/shape.h])
435 AC_TRY_COMPILE(
436#include <X11/Xlib.h>
437#include <X11/Xutil.h>
438#include <X11/extensions/shape.h>
439 , long foo = ShapeSet,
440 AC_MSG_RESULT([yes])
441 AC_DEFINE(SHAPE, [1], [Define to 1 if you have SHAPE])
442 LIBS="-lXext $LIBS"
443 FEATURES="$FEATURES SHAPE",
444 AC_MSG_RESULT([no])))],[
445 AC_MSG_RESULT([no])
446 CONFIGOPTS="$CONFIGOPTS --disable-shape"])
447
448
449
450dnl Check for RANDR support and proper library files.
451
452AC_MSG_CHECKING([whether to build support for the XRANDR (X Resize And Rotate) extension])
453AC_ARG_ENABLE(randr,
454 AS_HELP_STRING([--enable-randr], [XRANDR extension support (default=no)]),,[enable_randr=yes])
455
456AS_IF(test "x$enable_randr" = "xyes", [
457 AC_MSG_RESULT([yes])
458 AC_CHECK_LIB(Xrandr, XRRQueryExtension, [
459 AC_MSG_CHECKING([for X11/extensions/Xrandr.h])
460 AC_COMPILE_IFELSE([
461 AC_LANG_PROGRAM([[#include <X11/Xlib.h>
462#include <X11/Xutil.h>
463#include <X11/extensions/Xrandr.h>
464 ]], [[XRRQueryExtension(0, 0, 0);]]
465 )], [
466 AC_MSG_RESULT([yes])
467 AC_DEFINE(HAVE_RANDR, [1], [Define to 1 if you have RANDR])
468 LIBS="-lXrandr $LIBS"
469 FEATURES="$FEATURES RANDR"
470
471 AC_MSG_CHECKING([for XRRUpdateConfiguration])
472 AC_COMPILE_IFELSE([
473 AC_LANG_PROGRAM([[#include <X11/Xlib.h>
474#include <X11/Xutil.h>
475#include <X11/extensions/Xrandr.h>
476 ]], [[XRRUpdateConfiguration(0);]]
477 )], [
478 AC_MSG_RESULT([yes])
479 AC_DEFINE(HAVE_RANDR1_2, [1], [Define to 1 if you have RANDR 1.2])
480 ], [
481 AC_MSG_RESULT([no])
482 ])
483 ], [
484 AC_MSG_RESULT([no])
485 ])
486 ],[
487 AC_MSG_RESULT([no])
488 ])],[
489 AC_MSG_RESULT([no])
490 CONFIGOPTS="$CONFIGOPTS --disable-randr"])
491
492
493
494
495AC_MSG_CHECKING([whether to have FRIBIDI support])
496AC_ARG_ENABLE(fribidi,
497 AS_HELP_STRING([--enable-fribidi], [FRIBIDI support (default=yes)]), , [enable_fribidi=yes])
498AS_IF(test "x$enable_fribidi" = "xyes",[
499 AC_MSG_RESULT([yes])
500 AC_CHECK_LIB(fribidi, fribidi_version_info,
501 AC_MSG_CHECKING([for fribidi/fribidi.h])
502 AC_TRY_COMPILE(
503#include <fribidi/fribidi.h>
504 , fribidi_version_info,
505 AC_MSG_RESULT([yes])
506 AC_DEFINE(HAVE_FRIBIDI, [1], [Define to 1 if you have FRIBIDI])
507 LIBS="-lfribidi $LIBS",
508 AC_MSG_RESULT([no])))],[
509 AC_MSG_RESULT([no])
510 CONFIGOPTS="$CONFIGOPTS --disable-fribidi"])
511
512
513
514
515AC_ARG_WITH(menu,
516 AS_HELP_STRING([--with-menu=path],[location menu file (PREFIX/share/fluxbox/menu)]),
517 DEFAULT_MENU=$with_menu,
518 DEFAULT_MENU=\$\(prefix\)/share/fluxbox/menu
519)
520AC_SUBST(DEFAULT_MENU)
521
522AC_ARG_WITH(windowmenu,
523 AS_HELP_STRING([--with-windowmenu=path],[location windowmenu file (PREFIX/share/fluxbox/windowmenu)]),
524 DEFAULT_WINDOWMENU=$with_windowmenu,
525 DEFAULT_WINDOWMENU=\$\(prefix\)/share/fluxbox/windowmenu
526)
527AC_SUBST(DEFAULT_WINDOWMENU)
528
529AC_ARG_WITH(style,
530 AS_HELP_STRING([--with-style=path],[style by default (PREFIX/share/fluxbox/styles/bloe)]),
531 DEFAULT_STYLE=$with_style,
532 DEFAULT_STYLE=\$\(prefix\)/share/fluxbox/styles/bloe
533)
534AC_SUBST(DEFAULT_STYLE)
535
536AC_ARG_WITH(keys,
537 AS_HELP_STRING([--with-keys=path],[location keys file (PREFIX/share/fluxbox/keys)]),
538 DEFAULT_KEYS=$with_keys,
539 DEFAULT_KEYS=\$\(prefix\)/share/fluxbox/keys
540)
541AC_SUBST(DEFAULT_KEYS)
542
543AC_ARG_WITH(apps,
544 AS_HELP_STRING([--with-apps=path],[location apps file (PREFIX/share/fluxbox/apps)]),
545 DEFAULT_APPS=$with_apps,
546 DEFAULT_APPS=\$\(prefix\)/share/fluxbox/apps
547)
548AC_SUBST(DEFAULT_APPS)
549
550AC_ARG_WITH(overlay,
551 AS_HELP_STRING([--with-overlay=path],[location overlay file (PREFIX/share/fluxbox/overlay)]),
552 DEFAULT_OVERLAY=$with_overlay,
553 DEFAULT_OVERLAY=\$\(prefix\)/share/fluxbox/overlay
554)
555AC_SUBST(DEFAULT_OVERLAY)
556
557AC_ARG_WITH(init,
558 AS_HELP_STRING([--with-init=path],[location init file (PREFIX/share/fluxbox/init)]),
559 DEFAULT_INIT=$with_init,
560 DEFAULT_INIT=\$\(prefix\)/share/fluxbox/init
561)
562AC_SUBST(DEFAULT_INIT)
563
564# we have to expand locale_path in the config.h file, but NOT in the makefiles!
565AC_ARG_WITH(locale,
566 AS_HELP_STRING([--with-locale=path],[location for nls files (PREFIX/share/fluxbox/nls)]),
567 LOCALE_PATH=$with_locale
568 AC_DEFINE_UNQUOTED(LOCALEPATH, "$LOCALE_PATH", "location for nls files")
569 ,
570 LOCALE_PATH=\$\(prefix\)/share/fluxbox/nls
571 AC_DEFINE_UNQUOTED(LOCALEPATH, "$prefix/share/fluxbox/nls", "location for nls files")
572)
573AC_SUBST(LOCALE_PATH)
574
575AC_SUBST(program_prefix)
576AC_SUBST(program_suffix)
577
578dnl Determine the return type of signal handlers
579AC_TYPE_SIGNAL
580
581dnl Determine if maintainer portions of the Makefiles should be included.
582dnl AM_MAINTAINER_MODE
583
584dnl Output files
585AC_CONFIG_HEADER(config.h)
586
587AC_OUTPUT(Makefile
588version.h
589src/Makefile
590src/FbTk/Makefile
591src/tests/Makefile
592util/Makefile
593util/fbrun/Makefile
594data/Makefile
595data/styles/Makefile
596data/styles/BlueFlux/Makefile
597data/styles/BlueFlux/pixmaps/Makefile
598data/styles/Emerge/Makefile
599data/styles/Emerge/pixmaps/Makefile
600data/styles/arch/Makefile
601data/styles/arch/pixmaps/Makefile
602data/styles/zimek_bisque/Makefile
603data/styles/zimek_darkblue/Makefile
604data/styles/zimek_green/Makefile
605data/styles/ostrich/Makefile
606data/styles/green_tea/Makefile
607data/styles/bora_black/Makefile
608data/styles/bora_blue/Makefile
609data/styles/bora_green/Makefile
610data/styles/carp/Makefile
611data/styles/bloe/Makefile
612data/styles/bloe/pixmaps/Makefile
613doc/Makefile
614nls/Makefile
615nls/C/Makefile
616nls/be_BY/Makefile
617nls/bg_BG/Makefile
618nls/cs_CZ/Makefile
619nls/da_DK/Makefile
620nls/de_AT/Makefile
621nls/de_CH/Makefile
622nls/de_DE/Makefile
623nls/el_GR/Makefile
624nls/en_GB/Makefile
625nls/en_US/Makefile
626nls/es_AR/Makefile
627nls/es_ES/Makefile
628nls/et_EE/Makefile
629nls/fi_FI/Makefile
630nls/fr_CH/Makefile
631nls/fr_FR/Makefile
632nls/it_IT/Makefile
633nls/ja_JP/Makefile
634nls/ko_KR/Makefile
635nls/lv_LV/Makefile
636nls/mk_MK/Makefile
637nls/nb_NO/Makefile
638nls/nl_NL/Makefile
639nls/no_NO/Makefile
640nls/pl_PL/Makefile
641nls/pt_BR/Makefile
642nls/pt_PT/Makefile
643nls/ru_RU/Makefile
644nls/sk_SK/Makefile
645nls/sl_SI/Makefile
646nls/sv_SE/Makefile
647nls/tr_TR/Makefile
648nls/uk_UA/Makefile
649nls/vi_VN/Makefile
650nls/zh_CN/Makefile
651nls/zh_TW/Makefile
652)
653
654dnl Print results
655AC_MSG_RESULT([])
656AC_MSG_RESULT([ $PACKAGE version $VERSION configured successfully.])
657AC_MSG_RESULT([])
658AC_MSG_RESULT([Features:])
659AC_MSG_RESULT([ $FEATURES])
660AC_MSG_RESULT([])
661AC_MSG_RESULT([Using:])
662AC_MSG_RESULT([ '$prefix' for installation.])
663AC_MSG_RESULT([ '$DEFAULT_MENU' for location menu file.])
664AC_MSG_RESULT([ '$DEFAULT_STYLE' by default style.])
665AC_MSG_RESULT([ '$DEFAULT_KEYS' for location keys file.])
666AC_MSG_RESULT([ '$DEFAULT_INIT' for location init file.])
667AC_MSG_RESULT([ '$LOCALE_PATH' for nls files.])
668AC_MSG_RESULT([ '$CXX' for C++ compiler.])
669AC_MSG_RESULT([])
670AC_MSG_RESULT([Building with:])
671AC_MSG_RESULT([ '$CXXFLAGS' for C++ compiler flags.])
672AC_MSG_RESULT([ '$LIBS' for linker flags.])
673AC_MSG_RESULT([])
674AC_MSG_RESULT([Now build $PACKAGE with 'make'])
675AC_MSG_RESULT([])