aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMathias Gumz <akira@fluxbox.org>2015-01-05 14:08:32 (GMT)
committerMathias Gumz <mathias.gumz@gmail.com>2015-01-05 14:08:32 (GMT)
commitf8d0bd4cb303caad68c121a77974a3a0daa0c40e (patch)
tree94f2e1482a054e2316d8e3b8a066dcb6bdfc1f29 /configure.ac
parent0820bcb640e9030a99a4c47119df6b9305e632da (diff)
downloadfluxbox-f8d0bd4cb303caad68c121a77974a3a0daa0c40e.zip
fluxbox-f8d0bd4cb303caad68c121a77974a3a0daa0c40e.tar.bz2
Fix build-system: install data files (keys, apps, menu ...)
* Correctly build data files when operate outside of the $(srcdir) * Actually install data files * Use pkg-config to detect X11, works better on MacOSX. We used pkg-config already anyway, double checking for X11 does not yield better results. * Replace EXEEXT in some files while before installing them
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac26
1 files changed, 15 insertions, 11 deletions
diff --git a/configure.ac b/configure.ac
index 33217ad..d6d5612 100644
--- a/configure.ac
+++ b/configure.ac
@@ -194,14 +194,24 @@ dnl Check for networking libraries
194AC_CHECK_LIB([nsl], [t_open], [LIBS="-lnsl $LIBS"]) 194AC_CHECK_LIB([nsl], [t_open], [LIBS="-lnsl $LIBS"])
195AC_CHECK_LIB([socket], [socket], [LIBS="-lsocket $LIBS"]) 195AC_CHECK_LIB([socket], [socket], [LIBS="-lsocket $LIBS"])
196 196
197dnl Check for X headers and libraries 197#dnl Check for X headers and libraries
198AC_PATH_X 198#AC_PATH_X
199AC_PATH_XTRA 199#AC_PATH_XTRA
200AS_IF([test x$no_x = "xyes"], [ 200#AS_IF([test x$no_x = "xyes"], [
201# AC_MSG_ERROR([Fluxbox requires the X Window System libraries and headers.])
202#])
203
204dnl Check for X11
205PKG_CHECK_MODULES([X11], [ x11 ],
206 [AC_DEFINE([HAVE_X11], [1], [Define if x11 is available]) have_x11=yes],
207 [have_x11=no])
208AM_CONDITIONAL([X11], [test "$have_x11" = "yes"], AC_MSG_ERROR([Could not find XOpenDisplay in -lX11.]))
209AS_IF([test x$have_x11 = "xno"], [
201 AC_MSG_ERROR([Fluxbox requires the X Window System libraries and headers.]) 210 AC_MSG_ERROR([Fluxbox requires the X Window System libraries and headers.])
202]) 211])
203 212
204LIBS="$X_LIBS $LIBS" 213CXXFLAGS="$X11_CFLAGS $CXXFLAGS"
214LIBS="$X11_LIBS $LIBS"
205 215
206dnl Check for xpg4 216dnl Check for xpg4
207AC_CHECK_LIB([xpg4], [setlocale], [LIBS="-lxpg4 $LIBS"]) 217AC_CHECK_LIB([xpg4], [setlocale], [LIBS="-lxpg4 $LIBS"])
@@ -371,12 +381,6 @@ AS_IF([test "x$enable_imlib2" != "xno"], [
371]) 381])
372AM_CONDITIONAL([IMLIB2], [test "$have_imlib2" = "yes"]) 382AM_CONDITIONAL([IMLIB2], [test "$have_imlib2" = "yes"])
373 383
374dnl Check for X11
375PKG_CHECK_MODULES([X11], [ x11 ],
376 [AC_DEFINE([HAVE_X11], [1], [Define if x11 is available]) have_x11=yes],
377 [have_x11=no])
378AM_CONDITIONAL([X11], [test "$have_x11" = "yes"], AC_MSG_ERROR([Could not find XOpenDisplay in -lX11.]))
379
380dnl Check for X fonts 384dnl Check for X fonts
381have_xft=no 385have_xft=no
382AC_ARG_ENABLE([xft], AS_HELP_STRING([--disable-xft], [disable xft support])) 386AC_ARG_ENABLE([xft], AS_HELP_STRING([--disable-xft], [disable xft support]))