aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorMathias Gumz <akira@fluxbox.org>2015-01-05 14:08:32 (GMT)
committerMathias Gumz <mathias.gumz@gmail.com>2015-01-05 14:08:32 (GMT)
commitf8d0bd4cb303caad68c121a77974a3a0daa0c40e (patch)
tree94f2e1482a054e2316d8e3b8a066dcb6bdfc1f29 /Makefile.am
parent0820bcb640e9030a99a4c47119df6b9305e632da (diff)
downloadfluxbox-f8d0bd4cb303caad68c121a77974a3a0daa0c40e.zip
fluxbox-f8d0bd4cb303caad68c121a77974a3a0daa0c40e.tar.bz2
Fix build-system: install data files (keys, apps, menu ...)
* Correctly build data files when operate outside of the $(srcdir) * Actually install data files * Use pkg-config to detect X11, works better on MacOSX. We used pkg-config already anyway, double checking for X11 does not yield better results. * Replace EXEEXT in some files while before installing them
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am6
1 files changed, 6 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 1b09b39..f208e73 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -38,6 +38,10 @@ PROGRAM_SUFFIX=@program_suffix@
38# Do not rely on configure.ac AC_CONFIG_FILES for install paths. The 38# Do not rely on configure.ac AC_CONFIG_FILES for install paths. The
39# paths should be expanded at make time rather than configure. 39# paths should be expanded at make time rather than configure.
40edit_cmd = sed \ 40edit_cmd = sed \
41 -e 's|@default_style[@]|$(DEFAULT_STYLE)|g' \
42 -e 's|@default_menu[@]|$(DEFAULT_MENU)|g' \
43 -e 's|@default_keysfile[@]|$(DEFAULT_KEYSFILE)|g' \
44 -e 's|@default_appsfile[@]|$(DEFAULT_APPSFILE)|g' \
41 -e 's|@bindir[@]|$(bindir)|g' \ 45 -e 's|@bindir[@]|$(bindir)|g' \
42 -e 's|@datadir[@]|$(datadir)|g' \ 46 -e 's|@datadir[@]|$(datadir)|g' \
43 -e 's|@exec_prefix[@]|$(exec_prefix)|g' \ 47 -e 's|@exec_prefix[@]|$(exec_prefix)|g' \
@@ -53,6 +57,7 @@ edit_cmd = sed \
53 -e 's|@usrbin_execdir[@]|$(usrbin_execdir)|g' \ 57 -e 's|@usrbin_execdir[@]|$(usrbin_execdir)|g' \
54 -e 's|@usrlib_execdir[@]|$(usrlib_execdir)|g' \ 58 -e 's|@usrlib_execdir[@]|$(usrlib_execdir)|g' \
55 -e 's|@usrsbin_execdir[@]|$(usrsbin_execdir)|g' \ 59 -e 's|@usrsbin_execdir[@]|$(usrsbin_execdir)|g' \
60 -e 's|@EXEEXT[@]|$(EXEEXT)|g' \
56 -e 's|@VERSION[@]|$(VERSION)|g' 61 -e 's|@VERSION[@]|$(VERSION)|g'
57 62
58PATHFILES = 63PATHFILES =
@@ -60,6 +65,7 @@ CLEANFILES += $(PATHFILES)
60EXTRA_DIST += $(PATHFILES:=.in) 65EXTRA_DIST += $(PATHFILES:=.in)
61 66
62$(PATHFILES): Makefile 67$(PATHFILES): Makefile
68 $(MKDIR_P) $(dir $@)
63 @ rm -f $@ $@.tmp 69 @ rm -f $@ $@.tmp
64 $(AM_V_GEN) srcdir=''; \ 70 $(AM_V_GEN) srcdir=''; \
65 test -f ./$@.in || srcdir=$(srcdir)/; \ 71 test -f ./$@.in || srcdir=$(srcdir)/; \